Ignore:
Timestamp:
Dec 17, 2009, 5:56:04 PM (14 years ago)
Author:
broder
Message:

Pass --no-start to dh_installinit in invirt-dev and run the initscript
by hand.

This works around a bug where init scripts are started before Python
modules have been fully installed.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/packages/invirt-dev/debian/invirt-dev.postinst

    r2588 r2630  
    2121        fi
    2222
    23         invirt-build-conf
    24            
    2523        cat >>/etc/sudoers <<EOF
    2624### BEGIN invirt-dev
     
    2826### END invirt-dev
    2927EOF
     28
    3029        echo "-----"
    3130        echo "invirt-dev: run"
     
    4544    ;;
    4645esac
     46
     47if [ -x /etc/init.d/invirt-dev ]; then
     48    if hash invoke-rc.d 2>/dev/null; then
     49        invoke-rc.d invirt-dev start
     50    else
     51        /etc/init.d/invirt-dev start
     52    fi
     53fi
Note: See TracChangeset for help on using the changeset viewer.