source: package_branches/invirt-base/hvirt/debian/rules @ 2840

Last change on this file since 2840 was 2840, checked in by gdb, 14 years ago

Have init script operate in the style of xvm-munin-config

  • Property svn:executable set to *
  • Property svn:mime-type set to text/script
File size: 1.7 KB
RevLine 
[48]1#!/usr/bin/make -f
2
[1206]3DEB_PYTHON_SYSTEM=pysupport
[2776]4DEB_DIVERT_EXTENSION = .invirt
5# Stolen from Debathena
6DEB_CHECK_FILES_SOURCE_/etc/krb5.conf.invirt = \
7        /usr/share/kerberos-configs/krb5.conf.template
[2840]8DEB_DIVERT_FILES_invirt-base += \
9        /etc/ssh/sshd_config.invirt \
[2776]10        /etc/krb5.conf.invirt
[1206]11
[2840]12DEB_DH_INSTALLINIT_ARGS += --no-start
13DEB_UPDATE_RCD_PARAMS_invirt-base += defaults 20 80
14
[725]15include /usr/share/cdbs/1/rules/debhelper.mk
[1206]16include /usr/share/cdbs/1/class/python-distutils.mk
[2776]17include /usr/share/cdbs/1/rules/config-package.mk
[49]18
[1330]19binary-fixup/invirt-base::
[1218]20        mv $(DEB_DESTDIR)usr/bin/invirt-reload $(DEB_DESTDIR)usr/sbin/invirt-reload
21
[2840]22common-build-indep:: debian/sshd_config.invirt debian/krb5.conf.invirt.mako
[2787]23
[2776]24# Stolen from Debathena
25debian/sshd_config.invirt-orig: /var/lib/dpkg/info/openssh-server.postinst
26        perl -0pe 's/^.*<<EOF[^\n]*\n(.*\n)EOF\n.*$$/$$1/s or die;' $< > $@
27
28# Stolen from Debathena
29debian/sshd_config.invirt: debian/sshd_config.invirt-orig
30        perl -0pe '# Debathena rules (from debathena-ssh-server-config) \
[2787]31s/^#?GSSAPIAuthentication .*$$/GSSAPIAuthentication yes\nGSSAPIKeyExchange yes\nGSSAPIStrictAcceptorCheck no/m and \
32s/^#?GSSAPICleanupCredentials .*$$/GSSAPICleanupCredentials yes/m and \
33s/^#?ChallengeResponseAuthentication .*$$/ChallengeResponseAuthentication yes/m and \
[2776]34## In Debathena, privilege separation is configurable. \
[2787]35s/^#?UsePrivilegeSeparation .*$$/UsePrivilegeSeparation yes/m and \
36s/^#?PasswordAuthentication .*$$/PasswordAuthentication no/m or die;' $< > $@
[2776]37
[2840]38debian/krb5.conf.invirt.mako: $(call debian_check_files,/etc/krb5.conf)
39        debian/transform_krb5.conf.invirt.mako < $< > $@
40
[1206]41clean::
[1218]42        rm -rf python/invirt.egg-info
Note: See TracBrowser for help on using the repository browser.