source: package_branches/invirt-base/hvirt/debian/rules @ 2788

Last change on this file since 2788 was 2788, checked in by gdb, 14 years ago

Made the sshd divert work properly

  • Property svn:executable set to *
  • Property svn:mime-type set to text/script
File size: 1.4 KB
Line 
1#!/usr/bin/make -f
2
3DEB_PYTHON_SYSTEM=pysupport
4DEB_DIVERT_EXTENSION = .invirt
5# Stolen from Debathena
6DEB_CHECK_FILES_SOURCE_/etc/krb5.conf.invirt = \
7        /usr/share/kerberos-configs/krb5.conf.template
8DEB_TRANSFORM_FILES_invirt-base += \
9        /etc/krb5.conf.invirt
10DEB_DIVERT_FILES_invirt-base += \
11        /etc/ssh/sshd_config.invirt
12
13include /usr/share/cdbs/1/rules/debhelper.mk
14include /usr/share/cdbs/1/class/python-distutils.mk
15include /usr/share/cdbs/1/rules/config-package.mk
16
17binary-fixup/invirt-base::
18        mv $(DEB_DESTDIR)usr/bin/invirt-reload $(DEB_DESTDIR)usr/sbin/invirt-reload
19
20common-build-indep:: debian/sshd_config.invirt
21
22# Stolen from Debathena
23debian/sshd_config.invirt-orig: /var/lib/dpkg/info/openssh-server.postinst
24        perl -0pe 's/^.*<<EOF[^\n]*\n(.*\n)EOF\n.*$$/$$1/s or die;' $< > $@
25
26# Stolen from Debathena
27debian/sshd_config.invirt: debian/sshd_config.invirt-orig
28        perl -0pe '# Debathena rules (from debathena-ssh-server-config) \
29s/^#?GSSAPIAuthentication .*$$/GSSAPIAuthentication yes\nGSSAPIKeyExchange yes\nGSSAPIStrictAcceptorCheck no/m and \
30s/^#?GSSAPICleanupCredentials .*$$/GSSAPICleanupCredentials yes/m and \
31s/^#?ChallengeResponseAuthentication .*$$/ChallengeResponseAuthentication yes/m and \
32## In Debathena, privilege separation is configurable. \
33s/^#?UsePrivilegeSeparation .*$$/UsePrivilegeSeparation yes/m and \
34s/^#?PasswordAuthentication .*$$/PasswordAuthentication no/m or die;' $< > $@
35
36clean::
37        rm -rf python/invirt.egg-info
Note: See TracBrowser for help on using the repository browser.