Last change
on this file since 2485 was
295,
checked in by ecprice, 17 years ago
|
Improve postinst script to not give errors.
|
File size:
1.3 KB
|
Line | |
---|
1 | #!/bin/sh |
---|
2 | # postinst script for #PACKAGE# |
---|
3 | # |
---|
4 | # see: dh_installdeb(1) |
---|
5 | |
---|
6 | set -e |
---|
7 | |
---|
8 | # summary of how this script can be called: |
---|
9 | # * <postinst> `configure' <most-recently-configured-version> |
---|
10 | # * <old-postinst> `abort-upgrade' <new version> |
---|
11 | # * <conflictor's-postinst> `abort-remove' `in-favour' <package> |
---|
12 | # <new-version> |
---|
13 | # * <postinst> `abort-remove' |
---|
14 | # * <deconfigured's-postinst> `abort-deconfigure' `in-favour' |
---|
15 | # <failed-install-package> <version> `removing' |
---|
16 | # <conflicting-package> <version> |
---|
17 | # for details, see http://www.debian.org/doc/debian-policy/ or |
---|
18 | # the debian-policy package |
---|
19 | |
---|
20 | |
---|
21 | case "$1" in |
---|
22 | configure) |
---|
23 | #Don't create users on upgrade |
---|
24 | if [ -z "$2" ]; then |
---|
25 | # Don't fail if the user/database already exists |
---|
26 | su postgres -c 'createuser sipb-xen -S -d -R' || true |
---|
27 | su postgres -c 'createdb sipb_xen -O sipb-xen' || true |
---|
28 | adduser --system sipb-xen |
---|
29 | fi |
---|
30 | su sipb-xen -s /bin/sh -c 'sipb-xen-database-tables create' |
---|
31 | ;; |
---|
32 | |
---|
33 | abort-upgrade|abort-remove|abort-deconfigure) |
---|
34 | ;; |
---|
35 | |
---|
36 | *) |
---|
37 | echo "postinst called with unknown argument \`$1'" >&2 |
---|
38 | exit 1 |
---|
39 | ;; |
---|
40 | esac |
---|
41 | |
---|
42 | # dh_installdeb will replace this with shell code automatically |
---|
43 | # generated by other debhelper scripts. |
---|
44 | |
---|
45 | #DEBHELPER# |
---|
46 | |
---|
47 | exit 0 |
---|
48 | |
---|
49 | |
---|
Note: See
TracBrowser
for help on using the repository browser.