source: trunk/packages/sipb-xen-database/sipb-xen-database/debian/sipb-xen-database-server.postinst @ 81

Last change on this file since 81 was 81, checked in by nelhage, 17 years ago

A new version with less broken init scripts

File size: 1.2 KB
Line 
1#!/bin/sh
2# postinst script for #PACKAGE#
3#
4# see: dh_installdeb(1)
5
6set -e
7
8# summary of how this script can be called:
9#        * <postinst> `configure' <most-recently-configured-version>
10#        * <old-postinst> `abort-upgrade' <new version>
11#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
12#          <new-version>
13#        * <postinst> `abort-remove'
14#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
15#          <failed-install-package> <version> `removing'
16#          <conflicting-package> <version>
17# for details, see http://www.debian.org/doc/debian-policy/ or
18# the debian-policy package
19
20
21case "$1" in
22    configure)
23        # Don't fail if the user/database already exists
24        su postgres -c 'createuser sipb-xen -S -d -R'    || true
25        su postgres -c 'createdb sipb_xen -O sipb-xen'   || true
26        adduser --system sipb-xen
27
28        su sipb-xen -s /bin/sh -c 'sipb-xen-database-tables create'
29    ;;
30
31    abort-upgrade|abort-remove|abort-deconfigure)
32    ;;
33
34    *)
35        echo "postinst called with unknown argument \`$1'" >&2
36        exit 1
37    ;;
38esac
39
40# dh_installdeb will replace this with shell code automatically
41# generated by other debhelper scripts.
42
43#DEBHELPER#
44
45exit 0
46
47
Note: See TracBrowser for help on using the repository browser.