Opened 9 years ago

Closed 9 years ago

#112 closed defect (wontfix)

on /create: "Error: Device 768 (vbd) could not be connected"

Reported by: price Owned by:
Priority: minor Milestone:
Component: xen Version:
Keywords: Cc:

Description

What's up with this?

Error on operation /create for user jjzhu: "Error: Device 768 (vbd) could not be connected. Hotplug scripts not working.
" on "control jjzhu2 create windows-xp-sp2

Fields:
back=list
name=jjzhu2
description=Backup
memory=256
disksize=24.9
vmtype=linux-hvm
cd_or_auto=on
cdrom=windows-xp-sp2
owner=jjzhu

Error output:
---- end error output

Traceback (most recent call last):
  File "/var/www/sipb-xen-www/main.py", line 690, in __iter__
    output = handler(self.username, self.state, operation, fields)
  File "/var/www/sipb-xen-www/main.py", line 663, in handler
    return fun(username, state, path, fields)
  File "/var/www/sipb-xen-www/main.py", line 158, in create
    machine = controls.createVm(username, state, **parsed_fields)
  File "/var/www/sipb-xen-www/controls.py", line 148, in createVm
    bootMachine(machine, cdrom)
  File "/var/www/sipb-xen-www/controls.py", line 104, in bootMachine
    raise CodeError('"%s" on "control %s create %s'
CodeError: "Error: Device 768 (vbd) could not be connected. Hotplug scripts not working.
" on "control jjzhu2 create windows-xp-sp2

Change History (1)

comment:1 Changed 9 years ago by broder

  • Resolution set to wontfix
  • Status changed from new to closed

I believe this is related to using file: instead of the tap:aio: URI specification for CD images in the Xen config. This should be fixed by using phy: URIs (and LVs for CD images) on the prod cluster.

Note: See TracTickets for help on using tickets.