source: trunk/packages/xen-common/xen-common/debian/patches/network-bridge.dpatch @ 34

Last change on this file since 34 was 34, checked in by hartmans, 17 years ago

Add xen and xen-common

  • Property svn:executable set to *
File size: 717 bytes
Line 
1#! /bin/sh /usr/share/dpatch/dpatch-run
2## network-bridge.dpatch by Bastian Blank <waldi@debian.org>
3##
4## All lines beginning with `## DP:' are a description of the patch.
5## DP: Load netloop module
6
7@DPATCH@
8diff -urNad xen-common~/tools/examples/network-bridge xen-common/tools/examples/network-bridge
9--- xen-common~/tools/examples/network-bridge   2006-07-05 18:34:34.000000000 +0000
10+++ xen-common/tools/examples/network-bridge    2006-09-27 07:58:21.092674561 +0000
11@@ -59,6 +59,8 @@
12 findCommand "$@"
13 evalVariables "$@"
14 
15+modprobe netloop > /dev/null 2>&1 || true
16+
17 vifnum=${vifnum:-$(ip route list | awk '/^default / { print $NF }' | sed 's/^[^0-9]*//')}
18 vifnum=${vifnum:-0}
19 bridge=${bridge:-xenbr${vifnum}}
Note: See TracBrowser for help on using the repository browser.