Last change
on this file since 3042 was
2855,
checked in by broder, 15 years ago
|
Add an invirt-ssh-config package, based on debathena-ssh-server-config.
|
File size:
959 bytes
|
Rev | Line | |
---|
[2855] | 1 | #!/bin/sh |
---|
| 2 | # postinst script for debathena-ssh-server-config |
---|
| 3 | # |
---|
| 4 | # see: dh_installdeb(1) |
---|
| 5 | |
---|
| 6 | set -e |
---|
| 7 | |
---|
| 8 | # summary of how this script can be called: |
---|
| 9 | # * <postinst> `configure' <most-recently-configured-version> |
---|
| 10 | # * <old-postinst> `abort-upgrade' <new version> |
---|
| 11 | # * <conflictor's-postinst> `abort-remove' `in-favour' <package> |
---|
| 12 | # <new-version> |
---|
| 13 | # * <postinst> `abort-remove' |
---|
| 14 | # * <deconfigured's-postinst> `abort-deconfigure' `in-favour' |
---|
| 15 | # <failed-install-package> <version> `removing' |
---|
| 16 | # <conflicting-package> <version> |
---|
| 17 | # for details, see http://www.debian.org/doc/debian-policy/ or |
---|
| 18 | # the debian-policy package |
---|
| 19 | |
---|
| 20 | |
---|
| 21 | #DEBHELPER# |
---|
| 22 | |
---|
| 23 | case "$1" in |
---|
| 24 | configure) |
---|
| 25 | if hash invoke-rc.d; then |
---|
| 26 | invoke-rc.d ssh restart |
---|
| 27 | else |
---|
| 28 | /etc/init.d/ssh restart |
---|
| 29 | fi |
---|
| 30 | ;; |
---|
| 31 | |
---|
| 32 | abort-upgrade|abort-remove|abort-deconfigure) |
---|
| 33 | ;; |
---|
| 34 | |
---|
| 35 | *) |
---|
| 36 | echo "postinst called with unknown argument \`$1'" >&2 |
---|
| 37 | exit 1 |
---|
| 38 | ;; |
---|
| 39 | esac |
---|
Note: See
TracBrowser
for help on using the repository browser.