1 | #!/usr/bin/make -f |
---|
2 | |
---|
3 | DEB_PYTHON_SYSTEM=pysupport |
---|
4 | DEB_DIVERT_EXTENSION = .invirt |
---|
5 | # Stolen from Debathena |
---|
6 | DEB_CHECK_FILES_SOURCE_/etc/krb5.conf.invirt = \ |
---|
7 | /usr/share/kerberos-configs/krb5.conf.template |
---|
8 | DEB_DIVERT_FILES_invirt-base += \ |
---|
9 | /etc/ssh/sshd_config.invirt \ |
---|
10 | /etc/krb5.conf.invirt |
---|
11 | |
---|
12 | DEB_DH_INSTALLINIT_ARGS += --no-start |
---|
13 | DEB_UPDATE_RCD_PARAMS_invirt-base += defaults 20 80 |
---|
14 | |
---|
15 | include /usr/share/cdbs/1/rules/debhelper.mk |
---|
16 | include /usr/share/cdbs/1/class/python-distutils.mk |
---|
17 | include /usr/share/cdbs/1/rules/config-package.mk |
---|
18 | |
---|
19 | binary-fixup/invirt-base:: |
---|
20 | mv $(DEB_DESTDIR)usr/bin/invirt-reload $(DEB_DESTDIR)usr/sbin/invirt-reload |
---|
21 | |
---|
22 | common-build-indep:: debian/sshd_config.invirt debian/krb5.conf.invirt.mako |
---|
23 | |
---|
24 | # Stolen from Debathena |
---|
25 | debian/sshd_config.invirt-orig: /var/lib/dpkg/info/openssh-server.postinst |
---|
26 | perl -0pe 's/^.*<<EOF[^\n]*\n(.*\n)EOF\n.*$$/$$1/s or die;' $< > $@ |
---|
27 | |
---|
28 | # Stolen from Debathena |
---|
29 | debian/sshd_config.invirt: debian/sshd_config.invirt-orig |
---|
30 | perl -0pe '# Debathena rules (from debathena-ssh-server-config) \ |
---|
31 | s/^#?GSSAPIAuthentication .*$$/GSSAPIAuthentication yes\nGSSAPIKeyExchange yes\nGSSAPIStrictAcceptorCheck no/m and \ |
---|
32 | s/^#?GSSAPICleanupCredentials .*$$/GSSAPICleanupCredentials yes/m and \ |
---|
33 | s/^#?ChallengeResponseAuthentication .*$$/ChallengeResponseAuthentication yes/m and \ |
---|
34 | ## In Debathena, privilege separation is configurable. \ |
---|
35 | s/^#?UsePrivilegeSeparation .*$$/UsePrivilegeSeparation yes/m and \ |
---|
36 | s/^#?PasswordAuthentication .*$$/PasswordAuthentication no/m or die;' $< > $@ |
---|
37 | |
---|
38 | debian/krb5.conf.invirt.mako: $(call debian_check_files,/etc/krb5.conf) |
---|
39 | debian/transform_krb5.conf.invirt.mako < $< > $@ |
---|
40 | |
---|
41 | clean:: |
---|
42 | rm -rf python/invirt.egg-info |
---|