[48] | 1 | #!/usr/bin/make -f |
---|
| 2 | |
---|
[1206] | 3 | DEB_PYTHON_SYSTEM=pysupport |
---|
[2776] | 4 | DEB_DIVERT_EXTENSION = .invirt |
---|
| 5 | # Stolen from Debathena |
---|
| 6 | DEB_CHECK_FILES_SOURCE_/etc/krb5.conf.invirt = \ |
---|
| 7 | /usr/share/kerberos-configs/krb5.conf.template |
---|
| 8 | DEB_TRANSFORM_FILES_invirt-base += \ |
---|
| 9 | /etc/krb5.conf.invirt |
---|
[2788] | 10 | DEB_DIVERT_FILES_invirt-base += \ |
---|
[2787] | 11 | /etc/ssh/sshd_config.invirt |
---|
[1206] | 12 | |
---|
[725] | 13 | include /usr/share/cdbs/1/rules/debhelper.mk |
---|
[1206] | 14 | include /usr/share/cdbs/1/class/python-distutils.mk |
---|
[2776] | 15 | include /usr/share/cdbs/1/rules/config-package.mk |
---|
[49] | 16 | |
---|
[1330] | 17 | binary-fixup/invirt-base:: |
---|
[1218] | 18 | mv $(DEB_DESTDIR)usr/bin/invirt-reload $(DEB_DESTDIR)usr/sbin/invirt-reload |
---|
| 19 | |
---|
[2787] | 20 | common-build-indep:: debian/sshd_config.invirt |
---|
| 21 | |
---|
[2776] | 22 | # Stolen from Debathena |
---|
| 23 | debian/sshd_config.invirt-orig: /var/lib/dpkg/info/openssh-server.postinst |
---|
| 24 | perl -0pe 's/^.*<<EOF[^\n]*\n(.*\n)EOF\n.*$$/$$1/s or die;' $< > $@ |
---|
| 25 | |
---|
| 26 | # Stolen from Debathena |
---|
| 27 | debian/sshd_config.invirt: debian/sshd_config.invirt-orig |
---|
| 28 | perl -0pe '# Debathena rules (from debathena-ssh-server-config) \ |
---|
[2787] | 29 | s/^#?GSSAPIAuthentication .*$$/GSSAPIAuthentication yes\nGSSAPIKeyExchange yes\nGSSAPIStrictAcceptorCheck no/m and \ |
---|
| 30 | s/^#?GSSAPICleanupCredentials .*$$/GSSAPICleanupCredentials yes/m and \ |
---|
| 31 | s/^#?ChallengeResponseAuthentication .*$$/ChallengeResponseAuthentication yes/m and \ |
---|
[2776] | 32 | ## In Debathena, privilege separation is configurable. \ |
---|
[2787] | 33 | s/^#?UsePrivilegeSeparation .*$$/UsePrivilegeSeparation yes/m and \ |
---|
| 34 | s/^#?PasswordAuthentication .*$$/PasswordAuthentication no/m or die;' $< > $@ |
---|
[2776] | 35 | |
---|
[1206] | 36 | clean:: |
---|
[1218] | 37 | rm -rf python/invirt.egg-info |
---|