Last change
on this file since 2944 was
2940,
checked in by broder, 15 years ago
|
Run invirt-reload directly in the postinst of the fooconfig packages.
This replaces the old mechanism of using triggers. Activating triggers
via a package.triggers file doesn't seem to have taken off in the
Debian/Ubuntu? communities.
Instead, the standard approach seems to be to run the triggered
command as usual, and add logic to the triggered command to postpone
actually running itself until later.
|
-
Property svn:executable set to
*
|
File size:
986 bytes
|
Rev | Line | |
---|
[2940] | 1 | #!/bin/sh |
---|
| 2 | # postinst script for xvm-prodconfig |
---|
| 3 | # |
---|
| 4 | # see: dh_installdeb(1) |
---|
| 5 | |
---|
| 6 | set -e |
---|
| 7 | |
---|
| 8 | # summary of how this script can be called: |
---|
| 9 | # * <postinst> `configure' <most-recently-configured-version> |
---|
| 10 | # * <old-postinst> `abort-upgrade' <new version> |
---|
| 11 | # * <conflictor's-postinst> `abort-remove' `in-favour' <package> |
---|
| 12 | # <new-version> |
---|
| 13 | # * <postinst> `abort-remove' |
---|
| 14 | # * <deconfigured's-postinst> `abort-deconfigure' `in-favour' |
---|
| 15 | # <failed-install-package> <version> `removing' |
---|
| 16 | # <conflicting-package> <version> |
---|
| 17 | # for details, see http://www.debian.org/doc/debian-policy/ or |
---|
| 18 | # the debian-policy package |
---|
| 19 | |
---|
| 20 | |
---|
| 21 | case "$1" in |
---|
| 22 | configure) |
---|
| 23 | invirt-reload |
---|
| 24 | ;; |
---|
| 25 | |
---|
| 26 | abort-upgrade|abort-remove|abort-deconfigure) |
---|
| 27 | ;; |
---|
| 28 | |
---|
| 29 | *) |
---|
| 30 | echo "postinst called with unknown argument \`$1'" >&2 |
---|
| 31 | exit 1 |
---|
| 32 | ;; |
---|
| 33 | esac |
---|
| 34 | |
---|
| 35 | # dh_installdeb will replace this with shell code automatically |
---|
| 36 | # generated by other debhelper scripts. |
---|
| 37 | |
---|
| 38 | #DEBHELPER# |
---|
| 39 | |
---|
| 40 | exit 0 |
---|
Note: See
TracBrowser
for help on using the repository browser.