Last change
on this file since 2813 was
1781,
checked in by broder, 16 years ago
|
We don't need to remove the code from sudoers in the xvm-munin-config
postinst - the preinst will get run on upgrade
|
-
Property svn:executable set to
*
|
File size:
1.4 KB
|
Rev | Line | |
---|
[1761] | 1 | #!/bin/sh |
---|
| 2 | # postinst script for #PACKAGE# |
---|
| 3 | # |
---|
| 4 | # see: dh_installdeb(1) |
---|
| 5 | |
---|
| 6 | set -e |
---|
| 7 | |
---|
| 8 | # summary of how this script can be called: |
---|
| 9 | # * <postinst> `configure' <most-recently-configured-version> |
---|
| 10 | # * <old-postinst> `abort-upgrade' <new version> |
---|
| 11 | # * <conflictor's-postinst> `abort-remove' `in-favour' <package> |
---|
| 12 | # <new-version> |
---|
| 13 | # * <postinst> `abort-remove' |
---|
| 14 | # * <deconfigured's-postinst> `abort-deconfigure' `in-favour' |
---|
| 15 | # <failed-install-package> <version> `removing' |
---|
| 16 | # <conflicting-package> <version> |
---|
| 17 | # for details, see http://www.debian.org/doc/debian-policy/ or |
---|
| 18 | # the debian-policy package |
---|
| 19 | |
---|
| 20 | |
---|
| 21 | case "$1" in |
---|
| 22 | configure) |
---|
| 23 | # So munin can read the mail log |
---|
| 24 | adduser munin adm |
---|
| 25 | |
---|
| 26 | # So munin can sudo to get to postfix queue info |
---|
| 27 | cat >>/etc/sudoers <<EOF |
---|
| 28 | ### BEGIN xvm-munin-config |
---|
| 29 | munin ALL=(postfix) SETENV: NOPASSWD: /etc/munin/plugins/postfix_mailqueue |
---|
| 30 | munin ALL=(munin) SETENV: NOPASSWD: ALL |
---|
| 31 | ### END xvm-munin-config |
---|
| 32 | EOF |
---|
| 33 | |
---|
| 34 | # Install munin plugins that are now configured |
---|
| 35 | munin-node-configure --suggest --shell | sh |
---|
| 36 | |
---|
| 37 | invoke-rc.d munin-node restart |
---|
| 38 | ;; |
---|
| 39 | |
---|
| 40 | abort-upgrade|abort-remove|abort-deconfigure) |
---|
| 41 | ;; |
---|
| 42 | |
---|
| 43 | *) |
---|
| 44 | echo "postinst called with unknown argument \`$1'" >&2 |
---|
| 45 | exit 1 |
---|
| 46 | ;; |
---|
| 47 | esac |
---|
| 48 | |
---|
| 49 | # dh_installdeb will replace this with shell code automatically |
---|
| 50 | # generated by other debhelper scripts. |
---|
| 51 | |
---|
| 52 | #DEBHELPER# |
---|
| 53 | |
---|
| 54 | exit 0 |
---|
Note: See
TracBrowser
for help on using the repository browser.