[34] | 1 | #! /bin/sh /usr/share/dpatch/dpatch-run |
---|
| 2 | ## path-relative.dpatch by Bastian Blank <waldi@debian.org> |
---|
| 3 | ## |
---|
| 4 | ## All lines beginning with `## DP:' are a description of the patch. |
---|
| 5 | ## DP: No description. |
---|
| 6 | |
---|
| 7 | @DPATCH@ |
---|
| 8 | diff -urNad xen-common~/tools/examples/xmexample.hvm xen-common/tools/examples/xmexample.hvm |
---|
| 9 | --- xen-common~/tools/examples/xmexample.hvm 2006-08-22 11:56:30.000000000 +0200 |
---|
| 10 | +++ xen-common/tools/examples/xmexample.hvm 2006-09-21 23:45:52.000000000 +0200 |
---|
| 11 | @@ -6,16 +6,9 @@ |
---|
| 12 | # you can set the parameters for the domain on the xm command line. |
---|
| 13 | #============================================================================ |
---|
| 14 | |
---|
| 15 | -import os, re |
---|
| 16 | -arch = os.uname()[4] |
---|
| 17 | -if re.search('64', arch): |
---|
| 18 | - arch_libdir = 'lib64' |
---|
| 19 | -else: |
---|
| 20 | - arch_libdir = 'lib' |
---|
| 21 | - |
---|
| 22 | #---------------------------------------------------------------------------- |
---|
| 23 | # Kernel image file. |
---|
| 24 | -kernel = "/usr/lib/xen/boot/hvmloader" |
---|
| 25 | +kernel = "hvmloader" |
---|
| 26 | |
---|
| 27 | # The domain build function. HVM domain uses 'hvm'. |
---|
| 28 | builder='hvm' |
---|
| 29 | @@ -112,7 +105,7 @@ |
---|
| 30 | #============================================================================ |
---|
| 31 | |
---|
| 32 | # New stuff |
---|
| 33 | -device_model = '/usr/' + arch_libdir + '/xen/bin/qemu-dm' |
---|
| 34 | +device_model = 'qemu-dm' |
---|
| 35 | |
---|
| 36 | #----------------------------------------------------------------------------- |
---|
| 37 | # boot on floppy (a), hard disk (c) or CD-ROM (d) |
---|
| 38 | diff -urNad xen-common~/tools/examples/xmexample.vti xen-common/tools/examples/xmexample.vti |
---|
| 39 | --- xen-common~/tools/examples/xmexample.vti 2006-08-22 11:56:30.000000000 +0200 |
---|
| 40 | +++ xen-common/tools/examples/xmexample.vti 2006-09-21 23:46:29.000000000 +0200 |
---|
| 41 | @@ -6,10 +6,6 @@ |
---|
| 42 | # you can set the parameters for the domain on the xm command line. |
---|
| 43 | #============================================================================ |
---|
| 44 | |
---|
| 45 | -import os, re |
---|
| 46 | -arch = os.uname()[4] |
---|
| 47 | -arch_libdir = 'lib' |
---|
| 48 | - |
---|
| 49 | #---------------------------------------------------------------------------- |
---|
| 50 | # Kernel image file. |
---|
| 51 | kernel = "/usr/lib/xen/boot/guest_firmware.bin" |
---|
| 52 | @@ -64,7 +60,7 @@ |
---|
| 53 | #============================================================================ |
---|
| 54 | |
---|
| 55 | # New stuff |
---|
| 56 | -device_model = '/usr/' + arch_libdir + '/xen/bin/qemu-dm' |
---|
| 57 | +device_model = 'qemu-dm' |
---|
| 58 | |
---|
| 59 | # Advanced users only. Don't touch if you don't know what you're doing |
---|
| 60 | memmap = '/usr/lib/xen/boot/mem-map.sxp' |
---|