Last change
on this file since 34 was
34,
checked in by hartmans, 18 years ago
|
Add xen and xen-common
|
-
Property svn:executable set to
*
|
File size:
1.1 KB
|
Line | |
---|
1 | #! /bin/sh /usr/share/dpatch/dpatch-run |
---|
2 | ## arch.dpatch by Bastian Blank <waldi@debian.org> |
---|
3 | ## |
---|
4 | ## All lines beginning with `## DP:' are a description of the patch. |
---|
5 | ## DP: No description. |
---|
6 | |
---|
7 | @DPATCH@ |
---|
8 | diff -urNad xen-unstable~/tools/ioemu/configure xen-unstable/tools/ioemu/configure |
---|
9 | --- xen-unstable~/tools/ioemu/configure 2006-08-18 15:35:45.000000000 +0000 |
---|
10 | +++ xen-unstable/tools/ioemu/configure 2006-08-18 16:19:34.759859866 +0000 |
---|
11 | @@ -27,46 +27,18 @@ |
---|
12 | make="make" |
---|
13 | install="install" |
---|
14 | strip="strip" |
---|
15 | -cpu=`uname -m` |
---|
16 | target_list="" |
---|
17 | -case "$cpu" in |
---|
18 | - i386|i486|i586|i686|i86pc|BePC) |
---|
19 | +case "$XEN_TARGET_ARCH" in |
---|
20 | + x86_32) |
---|
21 | cpu="i386" |
---|
22 | ;; |
---|
23 | - armv*b) |
---|
24 | - cpu="armv4b" |
---|
25 | - ;; |
---|
26 | - armv*l) |
---|
27 | - cpu="armv4l" |
---|
28 | - ;; |
---|
29 | - alpha) |
---|
30 | - cpu="alpha" |
---|
31 | - ;; |
---|
32 | - "Power Macintosh"|ppc|ppc64) |
---|
33 | - cpu="powerpc" |
---|
34 | - ;; |
---|
35 | - mips) |
---|
36 | - cpu="mips" |
---|
37 | - ;; |
---|
38 | - s390) |
---|
39 | - cpu="s390" |
---|
40 | - ;; |
---|
41 | - sparc|sun4[muv]) |
---|
42 | - cpu="sparc" |
---|
43 | - ;; |
---|
44 | - sparc64) |
---|
45 | - cpu="sparc64" |
---|
46 | - ;; |
---|
47 | - ia64) |
---|
48 | - cpu="ia64" |
---|
49 | - ;; |
---|
50 | - m68k) |
---|
51 | - cpu="m68k" |
---|
52 | - ;; |
---|
53 | - x86_64|amd64) |
---|
54 | + x86_64) |
---|
55 | cpu="x86_64" |
---|
56 | libdir="lib64" |
---|
57 | ;; |
---|
58 | + powerpc) |
---|
59 | + cpu="powerpc" |
---|
60 | + ;; |
---|
61 | *) |
---|
62 | cpu="unknown" |
---|
63 | ;; |
---|
Note: See
TracBrowser
for help on using the repository browser.