source: trunk/packages/xen-3.1/xen-3.1/debian/patches/prefix-ioemu.dpatch @ 34

Last change on this file since 34 was 34, checked in by hartmans, 17 years ago

Add xen and xen-common

  • Property svn:executable set to *
File size: 1.6 KB
Line 
1#! /bin/sh /usr/share/dpatch/dpatch-run
2## libdir.dpatch by Bastian Blank <waldi@debian.org>
3## Forward ported to xen 3.0.2 by Guido Trotter <ultrotter@debian.org>
4##
5## All lines beginning with `## DP:' are a description of the patch.
6## DP: No description.
7
8@DPATCH@
9diff -urNad xen-3.0~/tools/firmware/Makefile xen-3.0/tools/firmware/Makefile
10--- xen-3.0~/tools/firmware/Makefile    2007-01-01 13:31:22.000000000 +0000
11+++ xen-3.0/tools/firmware/Makefile     2007-01-01 13:45:38.811446711 +0000
12@@ -4,7 +4,7 @@
13 # hvmloader is a 32-bit protected mode binary.
14 # It belongs in /usr/lib, not /usr/lib64.
15 TARGET      := hvmloader/hvmloader
16-INST_DIR := $(DESTDIR)/usr/lib/xen/boot
17+INST_DIR := $(DESTDIR)/usr/lib/xen-$(XEN_VERSION)/boot
18 
19 SUBDIRS :=
20 SUBDIRS += rombios
21diff -urNad xen-3.0~/tools/ioemu/Makefile.target xen-3.0/tools/ioemu/Makefile.target
22--- xen-3.0~/tools/ioemu/Makefile.target        2007-01-01 13:31:25.000000000 +0000
23+++ xen-3.0/tools/ioemu/Makefile.target 2007-01-01 13:45:23.676282285 +0000
24@@ -192,6 +192,7 @@
25 ifdef CONFIG_SOLARIS
26 LIBS+=-lsocket -lnsl -lresolv
27 endif
28+LIBS+=$(RPATH_ARG)
29 
30 # profiling code
31 ifdef TARGET_GPROF
32diff -urNad xen-3.0~/tools/ioemu/configure xen-3.0/tools/ioemu/configure
33--- xen-3.0~/tools/ioemu/configure      2007-01-01 13:31:26.000000000 +0000
34+++ xen-3.0/tools/ioemu/configure       2007-01-01 13:45:23.676282285 +0000
35@@ -514,9 +514,9 @@
36     prefix="/usr/local"
37 fi
38 mandir="$prefix/share/man"
39-datadir="$prefix/share/xen/qemu"
40+datadir="$prefix/share/xen-$XEN_VERSION/qemu"
41 docdir="$prefix/share/doc/qemu"
42-bindir="$prefix/$libdir/xen/bin"
43+bindir="$prefix/lib/xen-$XEN_VERSION/bin"
44 configdir="/etc/xen"
45 fi
46 
Note: See TracBrowser for help on using the repository browser.