source: trunk/packages/xen-3.1/xen-3.1/debian/patches/blktap-disable.dpatch @ 34

Last change on this file since 34 was 34, checked in by hartmans, 18 years ago

Add xen and xen-common

  • Property svn:executable set to *
File size: 1.7 KB
Line 
1#! /bin/sh /usr/share/dpatch/dpatch-run
2## blktap-disable.dpatch by Bastian Blank <waldi@debian.org>
3##
4## All lines beginning with `## DP:' are a description of the patch.
5## DP: No description.
6
7@DPATCH@
8diff -urNad xen-3.0~/tools/Makefile xen-3.0/tools/Makefile
9--- xen-3.0~/tools/Makefile     2007-01-01 13:31:17.000000000 +0000
10+++ xen-3.0/tools/Makefile      2007-01-01 13:51:07.342901844 +0000
11@@ -17,7 +17,6 @@
12 SUBDIRS-$(VTPM_TOOLS) += vtpm
13 SUBDIRS-y += xenstat
14 SUBDIRS-y += libaio
15-SUBDIRS-y += blktap
16 SUBDIRS-y += libfsimage
17 SUBDIRS-$(XENFB_TOOLS) += xenfb
18 SUBDIRS-$(LIBXENAPI_BINDINGS) += libxen
19diff -urNad xen-3.0~/tools/misc/xend xen-3.0/tools/misc/xend
20--- xen-3.0~/tools/misc/xend    2007-01-01 13:50:50.947812144 +0000
21+++ xen-3.0/tools/misc/xend     2007-01-01 13:51:34.617386944 +0000
22@@ -87,10 +87,6 @@
23     if os.fork() == 0:
24         os.execvp(sys.path[0] + '/xenconsoled', ['xenconsoled'])
25 
26-def start_blktapctrl():
27-    if os.fork() == 0:
28-        os.execvp(sys.path[0] + '/blktapctrl', ['blktapctrl'])
29-           
30 def main():
31     try:
32         check_logging()
33@@ -105,12 +101,10 @@
34         if os.uname()[0] != "SunOS":
35             start_xenstored()
36             start_consoled()
37-            start_blktapctrl()
38         return daemon.start()
39     elif sys.argv[1] == 'trace_start':
40         start_xenstored()
41         start_consoled()
42-        start_blktapctrl()
43         return daemon.start(trace=1)
44     elif sys.argv[1] == 'stop':
45         return daemon.stop()
46@@ -119,7 +113,6 @@
47     elif sys.argv[1] == 'restart':
48         start_xenstored()
49         start_consoled()
50-        start_blktapctrl()
51         return daemon.stop() or daemon.start()
52     elif sys.argv[1] == 'status':
53         return daemon.status()
Note: See TracBrowser for help on using the repository browser.