Last change
on this file since 531 was
308,
checked in by price, 17 years ago
|
err, actually writable
|
-
Property svn:executable set to
*
|
File size:
1.0 KB
|
Rev | Line | |
---|
[303] | 1 | #!/bin/sh |
---|
| 2 | # postinst script for #PACKAGE# |
---|
| 3 | # |
---|
| 4 | # see: dh_installdeb(1) |
---|
| 5 | |
---|
| 6 | set -e |
---|
| 7 | |
---|
| 8 | # summary of how this script can be called: |
---|
| 9 | # * <postinst> `configure' <most-recently-configured-version> |
---|
| 10 | # * <old-postinst> `abort-upgrade' <new version> |
---|
| 11 | # * <conflictor's-postinst> `abort-remove' `in-favour' <package> |
---|
| 12 | # <new-version> |
---|
| 13 | # * <postinst> `abort-remove' |
---|
| 14 | # * <deconfigured's-postinst> `abort-deconfigure' `in-favour' |
---|
| 15 | # <failed-install-package> <version> `removing' |
---|
| 16 | # <conflicting-package> <version> |
---|
| 17 | # for details, see http://www.debian.org/doc/debian-policy/ or |
---|
| 18 | # the debian-policy package |
---|
| 19 | |
---|
| 20 | |
---|
| 21 | case "$1" in |
---|
| 22 | configure) |
---|
| 23 | cd /var/www/sipb-xen-www |
---|
| 24 | make clean && make all |
---|
[307] | 25 | chgrp -R sipb-xen . |
---|
[308] | 26 | chmod -R g+w . |
---|
[303] | 27 | ;; |
---|
| 28 | |
---|
| 29 | abort-upgrade|abort-remove|abort-deconfigure) |
---|
| 30 | ;; |
---|
| 31 | |
---|
| 32 | *) |
---|
| 33 | echo "postinst called with unknown argument \`$1'" >&2 |
---|
| 34 | exit 1 |
---|
| 35 | ;; |
---|
| 36 | esac |
---|
| 37 | |
---|
| 38 | # dh_installdeb will replace this with shell code automatically |
---|
| 39 | # generated by other debhelper scripts. |
---|
| 40 | |
---|
| 41 | #DEBHELPER# |
---|
| 42 | |
---|
| 43 | exit 0 |
---|
| 44 | |
---|
| 45 | |
---|
Note: See
TracBrowser
for help on using the repository browser.