source: trunk/packages/sipb-xen-python-pydhcplib/debian/patches/non-standard-options.patch @ 377

Last change on this file since 377 was 377, checked in by broder, 16 years ago

Fix the DHCP server (fixes #44)

File size: 874 bytes
  • sipb-xen-python-pydhcp/pydhcplib/dhcp_basic_packet.py

     
    9999                             "char":[1,0,1], "16-bits":[2,0,1],
    100100                             "32-bits":[4,0,1], "identifier":[0,2,1]}
    101101           
    102             specs = fields_specs[DhcpOptionsTypes[DhcpOptions[name]]]
     102            specs = fields_specs.get(DhcpOptionsTypes[DhcpOptions[name]], [])
    103103            length = len(value)
    104             if (specs[0]!=0 and specs==length) or (specs[1]<=length and length%specs[2]==0):
     104            if specs == [] or (specs[0]!=0 and specs==length) or (specs[1]<=length and length%specs[2]==0):
    105105                self.options_data[name] = value
    106106                return True
    107107            else :
Note: See TracBrowser for help on using the repository browser.