Last change
on this file since 3 was
3,
checked in by hartmans, 17 years ago
|
Commit changes
|
-
Property svn:executable set to
*
-
Property svn:mime-type set to
text/script
|
File size:
1.7 KB
|
Rev | Line | |
---|
[1] | 1 | #!/usr/bin/make -f |
---|
| 2 | # -*- makefile -*- |
---|
| 3 | # Sample debian/rules that uses debhelper. |
---|
| 4 | # This file was originally written by Joey Hess and Craig Small. |
---|
| 5 | # As a special exception, when this file is copied by dh-make into a |
---|
| 6 | # dh-make output file, you may use that output file without restriction. |
---|
| 7 | # This special exception was added by Craig Small in version 0.37 of dh-make. |
---|
| 8 | |
---|
| 9 | # Uncomment this to turn on verbose mode. |
---|
| 10 | #export DH_VERBOSE=1 |
---|
| 11 | |
---|
| 12 | |
---|
| 13 | |
---|
| 14 | |
---|
| 15 | CFLAGS = -Wall -g |
---|
| 16 | |
---|
| 17 | ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS))) |
---|
| 18 | CFLAGS += -O0 |
---|
| 19 | else |
---|
| 20 | CFLAGS += -O2 |
---|
| 21 | endif |
---|
| 22 | |
---|
| 23 | configure: configure-stamp |
---|
| 24 | configure-stamp: |
---|
| 25 | dh_testdir |
---|
| 26 | # Add here commands to configure the package. |
---|
| 27 | |
---|
| 28 | touch configure-stamp |
---|
| 29 | |
---|
| 30 | |
---|
| 31 | build: build-stamp |
---|
| 32 | |
---|
| 33 | build-stamp: configure-stamp |
---|
| 34 | dh_testdir |
---|
| 35 | |
---|
| 36 | # Add here commands to compile the package. |
---|
| 37 | |
---|
| 38 | |
---|
| 39 | touch $@ |
---|
| 40 | |
---|
| 41 | clean: |
---|
| 42 | dh_testdir |
---|
| 43 | dh_testroot |
---|
| 44 | rm -f build-stamp configure-stamp |
---|
| 45 | |
---|
| 46 | # Add here commands to clean up after the build process. |
---|
| 47 | |
---|
| 48 | |
---|
| 49 | dh_clean |
---|
| 50 | |
---|
| 51 | install: build |
---|
| 52 | dh_testdir |
---|
| 53 | dh_testroot |
---|
| 54 | dh_clean -k |
---|
| 55 | dh_installdirs |
---|
| 56 | |
---|
| 57 | # Add here commands to install the package into debian/sipb-xen-dev. |
---|
| 58 | |
---|
| 59 | |
---|
| 60 | |
---|
| 61 | # Build architecture-independent files here. |
---|
| 62 | binary-arch: build install |
---|
| 63 | # We have nothing to do by default. |
---|
| 64 | |
---|
| 65 | # Build architecture-dependent files here. |
---|
| 66 | binary-indep: build install |
---|
| 67 | dh_testdir |
---|
| 68 | dh_testroot |
---|
| 69 | dh_installchangelogs |
---|
| 70 | dh_installdocs |
---|
| 71 | dh_installexamples |
---|
[3] | 72 | dh_install |
---|
[1] | 73 | # dh_installmenu |
---|
| 74 | # dh_installdebconf |
---|
| 75 | # dh_installlogrotate |
---|
| 76 | # dh_installemacsen |
---|
| 77 | # dh_installpam |
---|
| 78 | # dh_installmime |
---|
| 79 | # dh_python |
---|
| 80 | # dh_installinit |
---|
| 81 | # dh_installcron |
---|
| 82 | # dh_installinfo |
---|
| 83 | dh_installman |
---|
| 84 | dh_link |
---|
| 85 | dh_strip |
---|
| 86 | dh_compress |
---|
| 87 | dh_fixperms |
---|
| 88 | # dh_perl |
---|
| 89 | # dh_makeshlibs |
---|
| 90 | dh_installdeb |
---|
| 91 | dh_shlibdeps |
---|
| 92 | dh_gencontrol |
---|
| 93 | dh_md5sums |
---|
| 94 | dh_builddeb |
---|
| 95 | |
---|
| 96 | binary: binary-indep binary-arch |
---|
| 97 | .PHONY: build clean binary-indep binary-arch binary install configure |
---|
Note: See
TracBrowser
for help on using the repository browser.