source: trunk/packages/sipb-xen-dev/debian/sipb-xen-dev.postinst @ 956

Last change on this file since 956 was 956, checked in by price, 16 years ago

create repository user, etc, in sipb-xen-dev postinst

File size: 701 bytes
Line 
1#!/bin/sh
2set -e
3
4#DEBHELPER#
5
6case "$1" in
7    configure)
8        if [ -z "$2" ]; then
9            adduser --system repository
10            addgroup --system repo
11            echo "%repo   ALL=(repository)        ALWAYS_SET_HOME,NOPASSWD: /usr/bin/reprepro" >>/etc/sudoers
12            echo "-----"
13            echo "sipb-xen-dev: run"
14            echo "  adduser --disabled-password \$user"
15            echo "  adduser \$user repo"
16            echo "to make individual users that will build packages."
17            echo "-----"
18        fi
19    ;;
20
21    abort-upgrade|abort-remove|abort-deconfigure)
22    ;;
23
24    *)
25        echo "postinst called with unknown argument \`$1'" >&2
26        exit 1
27    ;;
28esac
Note: See TracBrowser for help on using the repository browser.