source: trunk/packages/sipb-xen-database/debian/sipb-xen-database-server.prerm @ 556

Last change on this file since 556 was 295, checked in by ecprice, 16 years ago

Improve postinst script to not give errors.

File size: 1.0 KB
Line 
1#!/bin/sh
2# prerm script for #PACKAGE#
3#
4# see: dh_installdeb(1)
5
6set -e
7
8# summary of how this script can be called:
9#        * <prerm> `remove'
10#        * <old-prerm> `upgrade' <new-version>
11#        * <new-prerm> `failed-upgrade' <old-version>
12#        * <conflictor's-prerm> `remove' `in-favour' <package> <new-version>
13#        * <deconfigured's-prerm> `deconfigure' `in-favour'
14#          <package-being-installed> <version> `removing'
15#          <conflicting-package> <version>
16# for details, see http://www.debian.org/doc/debian-policy/ or
17# the debian-policy package
18
19
20case "$1" in
21    remove|deconfigure)
22
23        # This will destroy data -- do we want to do this?
24        # su postgres -c 'dropdb sipb_xen'
25        # su postgres -c 'dropuser sipb-xen'
26        deluser sipb-xen
27    ;;
28
29    upgrade|failed-upgrade)
30    ;;
31
32    *)
33        echo "prerm called with unknown argument \`$1'" >&2
34        exit 1
35    ;;
36esac
37
38# dh_installdeb will replace this with shell code automatically
39# generated by other debhelper scripts.
40
41#DEBHELPER#
42
43exit 0
44
45
Note: See TracBrowser for help on using the repository browser.