Last change
on this file since 1673 was
1318,
checked in by price, 16 years ago
|
sipb-xen-www -> invirt-web
|
-
Property svn:executable set to
*
|
File size:
1.2 KB
|
Rev | Line | |
---|
[303] | 1 | #!/bin/sh |
---|
| 2 | # postinst script for #PACKAGE# |
---|
| 3 | # |
---|
| 4 | # see: dh_installdeb(1) |
---|
| 5 | |
---|
| 6 | set -e |
---|
| 7 | |
---|
| 8 | # summary of how this script can be called: |
---|
| 9 | # * <postinst> `configure' <most-recently-configured-version> |
---|
| 10 | # * <old-postinst> `abort-upgrade' <new version> |
---|
| 11 | # * <conflictor's-postinst> `abort-remove' `in-favour' <package> |
---|
| 12 | # <new-version> |
---|
| 13 | # * <postinst> `abort-remove' |
---|
| 14 | # * <deconfigured's-postinst> `abort-deconfigure' `in-favour' |
---|
| 15 | # <failed-install-package> <version> `removing' |
---|
| 16 | # <conflicting-package> <version> |
---|
| 17 | # for details, see http://www.debian.org/doc/debian-policy/ or |
---|
| 18 | # the debian-policy package |
---|
| 19 | |
---|
| 20 | |
---|
| 21 | case "$1" in |
---|
| 22 | configure) |
---|
[1318] | 23 | cd /var/www/invirt-web |
---|
[303] | 24 | make clean && make all |
---|
[1318] | 25 | chgrp -R invirt . |
---|
[308] | 26 | chmod -R g+w . |
---|
[1047] | 27 | |
---|
| 28 | # Our init script proxies all requests Apache's, so Apache's |
---|
| 29 | # running is just a NOP |
---|
| 30 | update-rc.d -f apache2 remove |
---|
[303] | 31 | ;; |
---|
| 32 | |
---|
| 33 | abort-upgrade|abort-remove|abort-deconfigure) |
---|
| 34 | ;; |
---|
| 35 | |
---|
| 36 | *) |
---|
| 37 | echo "postinst called with unknown argument \`$1'" >&2 |
---|
| 38 | exit 1 |
---|
| 39 | ;; |
---|
| 40 | esac |
---|
| 41 | |
---|
| 42 | # dh_installdeb will replace this with shell code automatically |
---|
| 43 | # generated by other debhelper scripts. |
---|
| 44 | |
---|
| 45 | #DEBHELPER# |
---|
| 46 | |
---|
| 47 | exit 0 |
---|
| 48 | |
---|
| 49 | |
---|
Note: See
TracBrowser
for help on using the repository browser.