Last change
on this file since 2440 was
1970,
checked in by quentin, 16 years ago
|
Generate VNC certificates that last for 2 years
|
-
Property svn:executable set to
*
|
File size:
1.5 KB
|
Line | |
---|
1 | #!/bin/sh |
---|
2 | # postinst script for #PACKAGE# |
---|
3 | # |
---|
4 | # see: dh_installdeb(1) |
---|
5 | |
---|
6 | set -e |
---|
7 | |
---|
8 | # summary of how this script can be called: |
---|
9 | # * <postinst> `configure' <most-recently-configured-version> |
---|
10 | # * <old-postinst> `abort-upgrade' <new version> |
---|
11 | # * <conflictor's-postinst> `abort-remove' `in-favour' <package> |
---|
12 | # <new-version> |
---|
13 | # * <postinst> `abort-remove' |
---|
14 | # * <deconfigured's-postinst> `abort-deconfigure' `in-favour' |
---|
15 | # <failed-install-package> <version> `removing' |
---|
16 | # <conflicting-package> <version> |
---|
17 | # for details, see http://www.debian.org/doc/debian-policy/ or |
---|
18 | # the debian-policy package |
---|
19 | |
---|
20 | |
---|
21 | case "$1" in |
---|
22 | configure) |
---|
23 | mkdir -p /etc/invirt/vnc |
---|
24 | if ! [ -e /etc/invirt/vnc/server.pem ]; then |
---|
25 | openssl genrsa -out /etc/invirt/vnc/server.pem 1024 >/dev/null |
---|
26 | fi |
---|
27 | |
---|
28 | if ! [ -e /etc/invirt/vnc/server.crt ]; then |
---|
29 | openssl req -new -x509 -nodes -sha1 -days 730 -subj "/CN=$(hostname -f)" -key /etc/invirt/vnc/server.pem \ |
---|
30 | > /etc/invirt/vnc/server.crt |
---|
31 | fi |
---|
32 | |
---|
33 | if ! [ -e /etc/invirt/vnc/token-key ]; then |
---|
34 | openssl rand -base64 33 >/etc/invirt/vnc/token-key |
---|
35 | fi |
---|
36 | ;; |
---|
37 | |
---|
38 | abort-upgrade|abort-remove|abort-deconfigure) |
---|
39 | ;; |
---|
40 | |
---|
41 | *) |
---|
42 | echo "postinst called with unknown argument \`$1'" >&2 |
---|
43 | exit 1 |
---|
44 | ;; |
---|
45 | esac |
---|
46 | |
---|
47 | # dh_installdeb will replace this with shell code automatically |
---|
48 | # generated by other debhelper scripts. |
---|
49 | |
---|
50 | #DEBHELPER# |
---|
51 | |
---|
52 | exit 0 |
---|
53 | |
---|
54 | |
---|
Note: See
TracBrowser
for help on using the repository browser.