source: trunk/packages/invirt-vnc-client/debian/invirt-vnc-client.postinst @ 1336

Last change on this file since 1336 was 1336, checked in by broder, 16 years ago

Add a script to regenerate the VNC client's certificate store

File size: 1000 bytes
Line 
1#!/bin/sh
2# postinst script for #PACKAGE#
3#
4# see: dh_installdeb(1)
5
6set -e
7
8# summary of how this script can be called:
9#        * <postinst> `configure' <most-recently-configured-version>
10#        * <old-postinst> `abort-upgrade' <new version>
11#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
12#          <new-version>
13#        * <postinst> `abort-remove'
14#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
15#          <failed-install-package> <version> `removing'
16#          <conflicting-package> <version>
17# for details, see http://www.debian.org/doc/debian-policy/ or
18# the debian-policy package
19
20
21case "$1" in
22    configure)
23        invirt-update-vnc-cert || true
24    ;;
25
26    abort-upgrade|abort-remove|abort-deconfigure)
27    ;;
28
29    *)
30        echo "postinst called with unknown argument \`$1'" >&2
31        exit 1
32    ;;
33esac
34
35# dh_installdeb will replace this with shell code automatically
36# generated by other debhelper scripts.
37
38#DEBHELPER#
39
40exit 0
41
42
Note: See TracBrowser for help on using the repository browser.