Last change
on this file since 2884 was
2630,
checked in by broder, 15 years ago
|
Pass --no-start to dh_installinit in invirt-dev and run the initscript
by hand.
This works around a bug where init scripts are started before Python
modules have been fully installed.
|
-
Property svn:executable set to
*
-
Property svn:mime-type set to
text/script
|
File size:
553 bytes
|
Rev | Line | |
---|
[1] | 1 | #!/usr/bin/make -f |
---|
| 2 | |
---|
[2548] | 3 | DEB_PYTHON_SYSTEM=pysupport |
---|
[1] | 4 | |
---|
[2630] | 5 | # We use --no-start instead of letting dh_installinit do its thing |
---|
| 6 | # because, in the postinst, dh_installinit's automatically added code |
---|
| 7 | # runs before dh_pysupport's automatically added code. |
---|
| 8 | # |
---|
| 9 | # This means that when the initscript is started, Python modules |
---|
| 10 | # installed by the package haven't been fully installed yet. |
---|
| 11 | DEB_DH_INSTALLINIT_ARGS += --no-start |
---|
| 12 | |
---|
[2548] | 13 | include /usr/share/cdbs/1/rules/debhelper.mk |
---|
| 14 | include /usr/share/cdbs/1/class/python-distutils.mk |
---|
[895] | 15 | |
---|
[2548] | 16 | clean:: |
---|
| 17 | rm -rf python/invirt.builder.egg-info |
---|
Note: See
TracBrowser
for help on using the repository browser.