Last change
on this file since 1428 was
1329,
checked in by price, 16 years ago
|
document adduser $user sbuild in invirt-dev postinst
|
File size:
742 bytes
|
Line | |
---|
1 | #!/bin/sh |
---|
2 | set -e |
---|
3 | |
---|
4 | #DEBHELPER# |
---|
5 | |
---|
6 | case "$1" in |
---|
7 | configure) |
---|
8 | if [ -z "$2" ]; then |
---|
9 | adduser --system repository |
---|
10 | addgroup --system repo |
---|
11 | echo "%repo ALL=(repository) ALWAYS_SET_HOME,NOPASSWD: /usr/bin/reprepro" >>/etc/sudoers |
---|
12 | echo "-----" |
---|
13 | echo "invirt-dev: run" |
---|
14 | echo " adduser --disabled-password \$user" |
---|
15 | echo " adduser \$user repo" |
---|
16 | echo " adduser \$user sbuild" |
---|
17 | echo "to make individual users that will build packages." |
---|
18 | echo "-----" |
---|
19 | fi |
---|
20 | ;; |
---|
21 | |
---|
22 | abort-upgrade|abort-remove|abort-deconfigure) |
---|
23 | ;; |
---|
24 | |
---|
25 | *) |
---|
26 | echo "postinst called with unknown argument \`$1'" >&2 |
---|
27 | exit 1 |
---|
28 | ;; |
---|
29 | esac |
---|
Note: See
TracBrowser
for help on using the repository browser.