source: trunk/packages/invirt-dev/debian/invirt-dev.postinst @ 2581

Last change on this file since 2581 was 2581, checked in by broder, 14 years ago

Update the Invirt git configuration at install-time.

  • Property svn:executable set to *
File size: 977 bytes
RevLine 
[956]1#!/bin/sh
2set -e
3
4#DEBHELPER#
5
6case "$1" in
7    configure)
[2556]8        if ! getent passwd repository >/dev/null 2>&1; then
[956]9            adduser --system repository
[2556]10        fi
11        if ! getent group repo >/dev/null 2>&1; then
[956]12            addgroup --system repo
[2556]13        fi
[2580]14
15        if ! getent passwd git >/dev/null 2>&1; then
16            adduser --system --home /srv/git --shell /usr/bin/git-shell git
17        fi
[2581]18
19        invirt-build-conf
[1770]20           
[2556]21        cat >>/etc/sudoers <<EOF
[1770]22### BEGIN invirt-dev
23%repo   ALL=(repository)        ALWAYS_SET_HOME,NOPASSWD: /usr/bin/reprepro
24### END invirt-dev
25EOF
[2556]26        echo "-----"
27        echo "invirt-dev: run"
28        echo "  adduser --disabled-password \$user"
29        echo "  adduser \$user repo"
30        echo "  adduser \$user sbuild"
31        echo "to make individual users that will build packages."
32        echo "-----"
[956]33    ;;
34
35    abort-upgrade|abort-remove|abort-deconfigure)
36    ;;
37
38    *)
39        echo "postinst called with unknown argument \`$1'" >&2
40        exit 1
41    ;;
42esac
Note: See TracBrowser for help on using the repository browser.