Last change
on this file since 2885 was
2798,
checked in by andersk, 15 years ago
|
Generate postgresql.conf with LC_ALL=en_US.UTF-8 pg_createcluster.
Generate a new /etc/postgresql/8.3/main/postgresql.conf with
pg_createcluster instead of taking it from the build host. Ensure
that it is generated with the en_US.UTF-8 locale.
|
-
Property svn:executable set to
*
|
File size:
976 bytes
|
Rev | Line | |
---|
[1288] | 1 | #!/usr/bin/make -f |
---|
| 2 | |
---|
| 3 | DEB_PYTHON_SYSTEM=pysupport |
---|
| 4 | |
---|
[2218] | 5 | DEB_DIVERT_EXTENSION = .invirt |
---|
| 6 | |
---|
| 7 | DEB_DIVERT_FILES_invirt-database-server += \ |
---|
[2798] | 8 | /etc/postgresql/8.3/main/postgresql.conf.invirt \ |
---|
[2218] | 9 | /etc/init.d/postgresql-8.3.invirt |
---|
| 10 | |
---|
[1288] | 11 | include /usr/share/cdbs/1/rules/debhelper.mk |
---|
| 12 | include /usr/share/cdbs/1/class/python-distutils.mk |
---|
[2218] | 13 | include /usr/share/cdbs/1/rules/config-package.mk |
---|
[1288] | 14 | |
---|
[2798] | 15 | common-build-indep:: debian/postgresql.conf.invirt |
---|
| 16 | |
---|
| 17 | debian/postgresql.conf.invirt: debian/transform_postgresql.conf.invirt |
---|
| 18 | set -e; \ |
---|
| 19 | export invirt_tmp="$$(mktemp -dt invirt-database.XXXXXX)"; \ |
---|
| 20 | PG_CLUSTER_CONF_ROOT="$$invirt_tmp/etc/postgresql" \ |
---|
| 21 | LC_ALL=en_US.UTF-8 \ |
---|
| 22 | pg_createcluster 8.3 main \ |
---|
| 23 | --datadir="$$invirt_tmp/var/lib/postgresql/8.3/main" \ |
---|
| 24 | --socketdir=/var/run/postgresql \ |
---|
| 25 | --port=5432; \ |
---|
| 26 | chmod +x $<; \ |
---|
| 27 | $< < "$$invirt_tmp/etc/postgresql/8.3/main/postgresql.conf" > $@; \ |
---|
| 28 | rm -rf "$$invirt_tmp" |
---|
| 29 | |
---|
[1288] | 30 | clean:: |
---|
[1962] | 31 | rm -rf invirt.database.egg-info |
---|
[2798] | 32 | rm -f debian/postgresql.conf.invirt |
---|
Note: See
TracBrowser
for help on using the repository browser.