source: trunk/packages/invirt-database/debian/invirt-database-server.postinst @ 2218

Last change on this file since 2218 was 2218, checked in by broder, 15 years ago

Merge invirt-database-server into invirt-database.

I...think this works, but I'm not making any promises.

File size: 1.6 KB
RevLine 
[77]1#!/bin/sh
[1288]2# postinst script for invirt-database-server
[77]3#
4# see: dh_installdeb(1)
5
6set -e
7
8# summary of how this script can be called:
9#        * <postinst> `configure' <most-recently-configured-version>
10#        * <old-postinst> `abort-upgrade' <new version>
11#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
12#          <new-version>
13#        * <postinst> `abort-remove'
14#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
15#          <failed-install-package> <version> `removing'
16#          <conflicting-package> <version>
17# for details, see http://www.debian.org/doc/debian-policy/ or
18# the debian-policy package
19
[918]20# dh_installdeb will replace this with shell code automatically
21# generated by other debhelper scripts.
22# Note that by moving this above our generated code we could run into significant problems
23# if we happened to start a daemon, and use debconf
24# We move this up here because we need the diversion of postgresql.conf to happen before we create tables
[77]25
[918]26#DEBHELPER#
27
28
[77]29case "$1" in
30    configure)
[295]31        #Don't create users on upgrade
32        if [ -z "$2" ]; then
33            # Don't fail if the user/database already exists
[1288]34            su postgres -c 'createuser invirt -S -d -R'    || true
35            su postgres -c 'createdb invirt -O invirt'   || true
36            adduser --system invirt
[295]37        fi
[1442]38        invoke-rc.d postgresql-8.3 restart
[1288]39        su invirt -s /bin/sh -c 'invirt-database-tables create'
[77]40    ;;
41
42    abort-upgrade|abort-remove|abort-deconfigure)
43    ;;
44
45    *)
46        echo "postinst called with unknown argument \`$1'" >&2
47        exit 1
48    ;;
49esac
50
51exit 0
52
53
Note: See TracBrowser for help on using the repository browser.