source: trunk/packages/invirt-database/debian/changelog @ 2200

Last change on this file since 2200 was 2200, checked in by price, 15 years ago

fix more imports EIBTI-style

File size: 13.4 KB
Line 
1invirt-database (0.1.8) unstable; urgency=low
2
3  [Peter Iannucci]
4  * Added Record superclass for models, handling __repr__ consistently.
5
6  [Greg Price]
7  invirt.database.record, .owner:
8  * use self.c rather than self.__dict__ for SQLAlchemy fields
9  * make Record._ignore, Owner.get* classmethods
10  * fold FormattableRecord, NullableRecord into Record
11  * shorten types in lists to __name__
12 
13  invirt-quota:
14  * refactor code that sets values
15  * print full help on no arguments
16
17  all:
18  * make EIBTI imports
19
20 -- Greg Price <price@mit.edu>  Fri, 27 Feb 2009 02:29:29 -0500
21
22invirt-database (0.1.7) unstable; urgency=low
23
24  * Disk quotas are measured in gibibytes.
25  * Rename invirt-setquotas to invirt-quota.
26  * Be explicit about units in invirt-quota.
27
28 -- Evan Broder <broder@mit.edu>  Tue, 17 Feb 2009 04:29:20 -0500
29
30invirt-database (0.1.6) unstable; urgency=low
31
32  * Move invirt-setquotas into this package.
33  * Don't explicitly initialize the values for each quota when creating a
34    new Owner object.
35
36 -- Evan Broder <broder@mit.edu>  Tue, 17 Feb 2009 03:44:20 -0500
37
38invirt-database (0.1.5) unstable; urgency=low
39
40  * Make the default values on the owners table explicit
41    (Note: This is a NOOP, since a nullable field with no otherwise
42    specified default defaults to NULL)
43
44 -- Evan Broder <broder@mit.edu>  Tue, 17 Feb 2009 03:36:47 -0500
45
46invirt-database (0.1.4) unstable; urgency=low
47
48  * minor bug fix
49
50 -- Peter A. Iannucci <iannucci@mit.edu>  Tue, 17 Feb 2009 02:59:14 -0500
51
52invirt-database (0.1.3) unstable; urgency=low
53
54  * Added owner table to database with ram, disk, and VM quotas
55  * Refactored Owner class into separate sourcefile
56
57 -- Peter A. Iannucci <iannucci@mit.edu>  Tue, 17 Feb 2009 01:31:53 -0500
58
59invirt-database (0.1.2) unstable; urgency=low
60
61  * Clean up the .egg-info directory from the right place.
62
63 -- Evan Broder <broder@mit.edu>  Mon, 05 Jan 2009 23:50:47 -0500
64
65invirt-database (0.1.1) unstable; urgency=low
66
67  * Correct a lintian spelling warning.
68
69 -- Evan Broder <broder@mit.edu>  Mon, 05 Jan 2009 23:40:44 -0500
70
71invirt-database (0.1.0) unstable; urgency=low
72
73  * Turn on lazy loading for all tables
74
75 -- Evan Broder <broder@mit.edu>  Mon, 17 Nov 2008 21:57:35 -0500
76
77invirt-database (0.0.6) unstable; urgency=low
78
79  * Let machines.administrator be NULL
80
81 -- Evan Broder <broder@mit.edu>  Mon, 17 Nov 2008 13:41:48 -0500
82
83invirt-database (0.0.5) unstable; urgency=low
84
85  * Add an architecture field to the autoinstaller table
86
87 -- Evan Broder <broder@mit.edu>  Mon, 17 Nov 2008 12:18:02 -0500
88
89invirt-database (0.0.3) unstable; urgency=low
90
91  * Add attributes to the ORM objects to connect mirrors and cdroms
92
93 -- Evan Broder <broder@mit.edu>  Tue, 28 Oct 2008 03:16:18 -0400
94
95invirt-database (0.0.2) unstable; urgency=low
96
97  * Export mirrors_table and Mirrors from invirt.database.models
98
99 -- Evan Broder <broder@mit.edu>  Tue, 28 Oct 2008 03:04:54 -0400
100
101invirt-database (0.0.1) unstable; urgency=low
102
103  * sipb-xen-database-common -> invirt-database
104  * sipb-xen-database-server -> invirt-database-server (a separate source package)
105  * sipb-xen-database-client -> invirt-xen-config
106
107 -- Evan Broder <broder@mit.edu>  Sat, 25 Oct 2008 19:22:46 -0400
108
109sipb-xen-database (10.36.1) unstable; urgency=low
110
111  * Typo in the new tables
112
113 -- Evan Broder <broder@mit.edu>  Sat, 25 Oct 2008 15:01:47 -0400
114
115sipb-xen-database (10.36) unstable; urgency=low
116
117  * Kill the remnants of the sipb_xen_database package
118  * Add the CDROM mirrors table
119
120 -- Evan Broder <broder@mit.edu>  Sat, 25 Oct 2008 14:48:32 -0400
121
122sipb-xen-database (10.35) unstable; urgency=low
123
124  * Shorten initscript with spiffy new library from sipb-xen-base
125
126 -- Greg Price <price@mit.edu>  Fri, 24 Oct 2008 07:25:56 -0400
127
128sipb-xen-database (10.34) unstable; urgency=low
129
130  * yet another new-sqlalchemy fix, this one post-0.4.2
131
132 -- Greg Price <price@mit.edu>  Thu, 23 Oct 2008 23:02:46 -0400
133
134sipb-xen-database (10.33) unstable; urgency=low
135
136  * Catch calls to restart Postgres and translate them into a sequential
137    stop, then start
138
139 -- Evan Broder <broder@mit.edu>  Mon, 20 Oct 2008 13:05:29 -0400
140
141sipb-xen-database (10.32) unstable; urgency=low
142
143  * invirt.database.clear_cache should actually do something
144
145 -- Evan Broder <broder@mit.edu>  Sun, 19 Oct 2008 02:02:37 -0400
146
147sipb-xen-database (10.31) unstable; urgency=low
148
149  * Database-managed VMs should never even think about bridging
150
151 -- Evan Broder <broder@mit.edu>  Sun, 19 Oct 2008 01:46:45 -0400
152
153sipb-xen-database (10.30.4) unstable; urgency=low
154
155  * Fix a typo in the CDROM image path
156
157 -- Evan Broder <broder@mit.edu>  Wed, 15 Oct 2008 13:21:10 -0400
158
159sipb-xen-database (10.30.3) unstable; urgency=low
160
161  * fix copy-paste errors in initscript: this is database, not console
162  * fix "typo" in initscript for package name printed in logs
163
164 -- Greg Price <price@mit.edu>  Sat, 11 Oct 2008 17:50:11 -0700
165
166sipb-xen-database (10.30.2) unstable; urgency=low
167
168  * Fix a typo in the CDROM lookup in sipb-database
169
170 -- Evan Broder <broder@mit.edu>  Sat, 11 Oct 2008 19:17:05 -0400
171
172sipb-xen-database (10.30.1) unstable; urgency=low
173
174  * Don't strip quotes that won't be there
175
176 -- Evan Broder <broder@mit.edu>  Fri, 10 Oct 2008 01:48:48 -0400
177
178sipb-xen-database (10.30) unstable; urgency=low
179
180  * Look for CD images in /dev/xenvg/image_* and validate image name from
181    the database
182  * Pass the installer arguments unaltered to the kernel, matching the
183    remctl interface
184
185 -- Evan Broder <broder@mit.edu>  Thu, 09 Oct 2008 02:09:42 -0400
186
187sipb-xen-database (10.29) unstable; urgency=low
188
189  * Some fixes in the sipb-database script
190
191 -- Evan Broder <broder@mit.edu>  Mon, 06 Oct 2008 18:55:24 -0400
192
193sipb-xen-database (10.28) unstable; urgency=low
194
195  * Re-establish the database connection if the server goes AWOL
196
197 -- Evan Broder <broder@mit.edu>  Sat, 04 Oct 2008 23:19:59 -0400
198
199sipb-xen-database (10.27) unstable; urgency=low
200
201  * Update sipb-database to work with newer SQLAlchemy and Xen
202
203 -- Evan Broder <broder@mit.edu>  Fri, 03 Oct 2008 20:08:16 -0400
204
205sipb-xen-database (10.26.1) unstable; urgency=low
206
207  * We want autoflush off, too
208
209 -- Evan Broder <broder@mit.edu>  Fri, 03 Oct 2008 19:22:12 -0400
210
211sipb-xen-database (10.26) unstable; urgency=low
212
213  * Disable transactions by default
214
215 -- Evan Broder <broder@mit.edu>  Thu, 02 Oct 2008 19:40:34 -0400
216
217sipb-xen-database (10.25) unstable; urgency=low
218
219  * add remote and console to pg_hba.conf template
220  * fix init script so it works
221  * port more code to sqlalchemy 0.4
222
223 -- Greg Price <price@mit.edu>  Wed, 01 Oct 2008 19:30:26 -0400
224
225sipb-xen-database (10.24) unstable; urgency=low
226
227  * Update postgresql.conf for Hardy
228
229 -- Evan Broder <broder@mit.edu>  Wed, 01 Oct 2008 03:12:36 -0400
230
231sipb-xen-database (10.23) unstable; urgency=low
232
233  * switch to postgresql 8.3, as 8.1 isn't in hardy
234
235 -- Greg Price <price@mit.edu>  Wed, 01 Oct 2008 02:09:43 -0400
236
237sipb-xen-database (10.22) unstable; urgency=low
238
239  * depend on postgresql without specifying old version 8.1
240
241 -- Greg Price <price@mit.edu>  Wed, 01 Oct 2008 01:55:49 -0400
242
243sipb-xen-database (10.21) unstable; urgency=low
244
245  * fix distribution
246
247 -- Greg Price <price@mit.edu>  Tue, 30 Sep 2008 23:50:25 -0400
248
249sipb-xen-database (10.20) hardy; urgency=low
250
251  * port to sqlalchemy-0.4, which cuts out some newly deprecated
252    interfaces and allowed some still-present interfaces to bitrot
253
254 -- Greg Price <price@mit.edu>  Mon, 29 Sep 2008 06:06:21 +0000
255
256sipb-xen-database (10.19) unstable; urgency=low
257
258  * Generate config files for pg_hba.conf
259  * replace postgresql.conf
260
261 --  Sam Hartman <hartmans@xvm.mit.edu>  Mon, 25 Aug 2008 00:38:21 +0000
262
263sipb-xen-database (10.18) unstable; urgency=low
264
265  * add 'adminable' column to machines; for selectively, temporarily,
266    enabling admin mode on a machine
267
268 -- Greg Price <price@mit.edu>  Wed,  6 Aug 2008 01:02:59 -0400
269
270sipb-xen-database (10.17) unstable; urgency=low
271
272  * pull IP gateway, network from config
273  * configurabilization complete!
274
275 -- Greg Price <price@mit.edu>  Sun,  3 Aug 2008 01:16:53 -0400
276
277sipb-xen-database (10.16) unstable; urgency=low
278
279  in sipb-xen-database-tables:
280  * use invirt.database, and take default db uri
281
282 -- Greg Price <price@mit.edu>  Sun,  3 Aug 2008 00:51:32 -0400
283
284sipb-xen-database (10.15) unstable; urgency=low
285
286  in /etc/xen/database:
287  * uncommitted changes on black-mesa
288  * sipb_xen_database -> invirt.database
289  * use default db uri
290
291  in invirt.database:
292  * get default db uri from invirt.config
293
294 -- Greg Price <price@mit.edu>  Sun,  3 Aug 2008 00:26:46 -0400
295
296sipb-xen-database (10.14) unstable; urgency=low
297
298  * Rename sipb_xen_database -> invirt.database,
299    keeping old name too for now, for compatibility.
300
301 -- Greg Price <price@mit.edu>  Sat,  2 Aug 2008 23:19:18 -0400
302
303sipb-xen-database (10.13) unstable; urgency=low
304
305  * Modify autoinstalls table to specify distribution/mirror.
306
307 -- Eric Price <ecprice@pseudomyrmex.mit.edu>  Sat, 21 Jun 2008 21:25:21 -0400
308
309sipb-xen-database (10.12) unstable; urgency=low
310
311  * Add a description field.
312
313 -- Anders Kaseorg <andersk@mit.edu>  Wed, 18 Jun 2008 03:52:49 -0400
314
315sipb-xen-database (10.11) unstable; urgency=low
316
317  * Specify ON DELETE CASCADE
318
319 -- Eric Price <ecprice@pseudomyrmex.mit.edu>  Fri, 06 Jun 2008 12:25:35 -0400
320
321sipb-xen-database (10.10) unstable; urgency=low
322
323  * Make machine.acl a private relation.
324
325 -- Eric Price <ecprice@pseudomyrmex.mit.edu>  Fri, 06 Jun 2008 12:03:09 -0400
326
327sipb-xen-database (10.9) unstable; urgency=low
328
329  * Eager loading of relations for better performance.
330
331 -- Eric Price <ecprice@pseudomyrmex.mit.edu>  Mon, 02 Jun 2008 01:39:11 -0400
332
333sipb-xen-database (10.8) unstable; urgency=low
334
335  * Configure serial console on boot
336
337 -- Quentin Smith <quentin@sipb-xen-dev.mit.edu>  Thu,  1 May 2008 20:21:25 -0400
338
339sipb-xen-database (10.7) unstable; urgency=low
340
341  * Depend on psql client in -client package.
342
343 -- Greg Price <price@mit.edu>  Sat, 26 Apr 2008 21:06:41 -0400
344
345sipb-xen-database (10.6) unstable; urgency=low
346
347  * Support autoinstalls table.
348
349 -- Eric Price <ecprice@pseudomyrmex.mit.edu>  Mon, 21 Apr 2008 22:34:46 -0400
350
351sipb-xen-database (10.5) unstable; urgency=low
352
353  * Enable USB tablet device in guests.
354
355 -- Anders Kaseorg <andersk@mit.edu>  Mon, 21 Apr 2008 17:39:59 -0400
356
357sipb-xen-database (10.4.1) unstable; urgency=low
358
359  * Actually export the cache clearing function.
360
361 -- Eric Price <ecprice@pseudomyrmex.mit.edu>  Fri, 28 Mar 2008 21:18:01 -0400
362
363sipb-xen-database (10.4) unstable; urgency=low
364
365  * Ubuntu's dch sucks.
366
367 -- Eric Price <ecprice@sipb-xen-dev.mit.edu>  Fri, 28 Mar 2008 20:43:42 -0400
368
369sipb-xen-database (10.3ubuntu1) gutsy; urgency=low
370
371  * Expose a function for clearing the cache.
372
373 -- Eric Price <ecprice@pseudomyrmex.mit.edu>  Fri, 28 Mar 2008 20:31:06 -0400
374
375sipb-xen-database (10.3) unstable; urgency=low
376
377  * Use 'acl', not 'users', for the reference to the machine_access table.
378
379 -- Eric Price <ecprice@sipb-xen-dev.mit.edu>  Thu, 24 Jan 2008 17:23:33 -0500
380
381sipb-xen-database (10.2) unstable; urgency=low
382
383  * Add MachineAccess to __all__ so it can be imported
384  * Remove unnecessary constructors for database objects
385
386 -- Quentin Smith <quentin@sipb-xen-dev.mit.edu>  Mon, 12 Nov 2007 04:53:47 -0500
387
388sipb-xen-database (10.1) unstable; urgency=low
389
390  * Make sipb-xen-database-tables safer (don't default to drop_all)
391
392 -- Quentin Smith <quentin@sipb-xen-dev.mit.edu>  Mon, 12 Nov 2007 04:39:59 -0500
393
394sipb-xen-database (10) unstable; urgency=low
395
396  * Added a machine_access table for cached ACLs
397
398 -- Quentin Smith <quentin@sipb-xen-dev.mit.edu>  Mon, 12 Nov 2007 04:24:35 -0500
399
400sipb-xen-database (9.0) unstable; urgency=low
401
402  * No changes.
403
404 -- Eric Price <ecprice@sipb-xen-dev.mit.edu>  Wed, 10 Oct 2007 00:17:20 -0400
405
406sipb-xen-database (9) unstable; urgency=low
407
408  * Add administrator column and backrefs to machine.
409
410 -- Eric Price <ecprice@sipb-xen-dev.mit.edu>  Wed, 10 Oct 2007 00:11:47 -0400
411
412sipb-xen-database (8) gutsy; urgency=low
413
414  * Prepend d_ to database VMs.
415
416 -- Eric Price <ecprice@sipb-xen-dev.mit.edu>  Tue,  9 Oct 2007 02:35:51 -0400
417
418sipb-xen-database (7.00002) gutsy; urgency=low
419
420  * Actually import re.
421
422 -- Anders Kaseorg <andersk@mit.edu>  Sun, 07 Oct 2007 04:34:07 -0400
423
424sipb-xen-database (7.00001) gutsy; urgency=low
425
426  * import re.
427
428 -- Anders Kaseorg <andersk@mit.edu>  Sun, 07 Oct 2007 03:40:25 -0400
429
430sipb-xen-database (7) unstable; urgency=low
431
432  * nics primary key should be mac address, not hostname.
433  * Make ip unique, and constructor for nics.
434  * Add a table for boot CDs.
435  * Add cdrom_image parameter.
436  * Regex sanity checking.
437
438 -- Anders Kaseorg <andersk@mit.edu>  Sun, 07 Oct 2007 03:18:30 -0400
439
440sipb-xen-database (6) unstable; urgency=low
441
442  * Adding a script to create lvm volumes
443
444 -- Nelson Elhage <nelhage@mit.edu>  Sat, 22 Sep 2007 13:59:36 -0400
445
446sipb-xen-database (5) unstable; urgency=low
447
448  * Change the host from sipb-vm-1 to sipb-xen-dev
449
450 -- Nelson Elhage <nelhage@mit.edu>  Sat,  8 Sep 2007 16:16:07 -0400
451
452sipb-xen-database (4) unstable; urgency=low
453
454  * Add script=vif-sipbroute to our vif lines
455
456 -- Nelson Elhage <nelhage@mit.edu>  Fri, 24 Aug 2007 22:07:18 -0400
457
458sipb-xen-database (3) unstable; urgency=low
459
460  * Add a connect() line to sipb-database
461  * Fix some other bugs in sipb-database
462
463 -- Nelson Elhage <nelhage@mit.edu>  Sun, 19 Aug 2007 19:40:08 -0400
464
465sipb-xen-database (2) unstable; urgency=low
466
467  * Fix the postinit and prerm scripts to create a sipb-xen user
468
469 -- Nelson Elhage <nelhage@mit.edu>  Thu, 16 Aug 2007 16:27:36 -0400
470
471sipb-xen-database (1) unstable; urgency=low
472
473  * Initial Release.
474
475 -- Nelson Elhage <nelhage@mit.edu>  Sun, 15 Jul 2007 16:01:16 -0400
Note: See TracBrowser for help on using the repository browser.