Last change
on this file since 1904 was
1815,
checked in by broder, 16 years ago
|
Merge invirt-console-server into invirt-console (LP: #305681)
|
-
Property svn:executable set to
*
|
File size:
1.3 KB
|
Line | |
---|
1 | #!/bin/sh |
---|
2 | # postinst script for invirt-console-host |
---|
3 | # |
---|
4 | # see: dh_installdeb(1) |
---|
5 | |
---|
6 | set -e |
---|
7 | |
---|
8 | # summary of how this script can be called: |
---|
9 | # * <postinst> `configure' <most-recently-configured-version> |
---|
10 | # * <old-postinst> `abort-upgrade' <new version> |
---|
11 | # * <conflictor's-postinst> `abort-remove' `in-favour' <package> |
---|
12 | # <new-version> |
---|
13 | # * <postinst> `abort-remove' |
---|
14 | # * <deconfigured's-postinst> `abort-deconfigure' `in-favour' |
---|
15 | # <failed-install-package> <version> `removing' |
---|
16 | # <conflicting-package> <version> |
---|
17 | # for details, see http://www.debian.org/doc/debian-policy/ or |
---|
18 | # the debian-policy package |
---|
19 | |
---|
20 | |
---|
21 | case "$1" in |
---|
22 | configure) |
---|
23 | # Clean up the old sudoers line before we add it back |
---|
24 | perl -i.bak -ne 's%^### (BEGIN|END) invirt-console-host\s*$%%m && ($skip = ($1 eq "BEGIN")); print unless $skip;' /etc/sudoers |
---|
25 | |
---|
26 | cat >>/etc/sudoers <<EOF |
---|
27 | ### BEGIN invirt-console-host |
---|
28 | conservr ALL=(ALL) NOPASSWD: /usr/sbin/xm console d_* |
---|
29 | ### END invirt-console-host |
---|
30 | EOF |
---|
31 | ;; |
---|
32 | |
---|
33 | abort-upgrade|abort-remove|abort-deconfigure) |
---|
34 | ;; |
---|
35 | |
---|
36 | *) |
---|
37 | echo "postinst called with unknown argument \`$1'" >&2 |
---|
38 | exit 1 |
---|
39 | ;; |
---|
40 | esac |
---|
41 | |
---|
42 | # dh_installdeb will replace this with shell code automatically |
---|
43 | # generated by other debhelper scripts. |
---|
44 | |
---|
45 | #DEBHELPER# |
---|
46 | |
---|
47 | exit 0 |
---|
Note: See
TracBrowser
for help on using the repository browser.