Last change
on this file since 3029 was
3011,
checked in by broder, 14 years ago
|
Use the .. Perl operator to simplify prerms.
invirt-console-host, invirt-dev, and all of the packages in
xvm-munin-config previously used a convoluted one-liner to clean up
/etc/sudoers, but we can do it much more easily using the .. operator.
Taken from http://blog.ksplice.com/2010/05/top-10-perl-one-liner-tricks/
|
-
Property svn:executable set to
*
|
File size:
1.1 KB
|
Rev | Line | |
---|
[1118] | 1 | #!/bin/sh |
---|
[1187] | 2 | # postinst script for invirt-console-host |
---|
[1118] | 3 | # |
---|
| 4 | # see: dh_installdeb(1) |
---|
| 5 | |
---|
| 6 | set -e |
---|
| 7 | |
---|
| 8 | # summary of how this script can be called: |
---|
| 9 | # * <postinst> `configure' <most-recently-configured-version> |
---|
| 10 | # * <old-postinst> `abort-upgrade' <new version> |
---|
| 11 | # * <conflictor's-postinst> `abort-remove' `in-favour' <package> |
---|
| 12 | # <new-version> |
---|
| 13 | # * <postinst> `abort-remove' |
---|
| 14 | # * <deconfigured's-postinst> `abort-deconfigure' `in-favour' |
---|
| 15 | # <failed-install-package> <version> `removing' |
---|
| 16 | # <conflicting-package> <version> |
---|
| 17 | # for details, see http://www.debian.org/doc/debian-policy/ or |
---|
| 18 | # the debian-policy package |
---|
| 19 | |
---|
| 20 | |
---|
| 21 | case "$1" in |
---|
| 22 | configure) |
---|
| 23 | cat >>/etc/sudoers <<EOF |
---|
[1187] | 24 | ### BEGIN invirt-console-host |
---|
[1118] | 25 | conservr ALL=(ALL) NOPASSWD: /usr/sbin/xm console d_* |
---|
[1187] | 26 | ### END invirt-console-host |
---|
[1118] | 27 | EOF |
---|
| 28 | ;; |
---|
| 29 | |
---|
| 30 | abort-upgrade|abort-remove|abort-deconfigure) |
---|
| 31 | ;; |
---|
| 32 | |
---|
| 33 | *) |
---|
| 34 | echo "postinst called with unknown argument \`$1'" >&2 |
---|
| 35 | exit 1 |
---|
| 36 | ;; |
---|
| 37 | esac |
---|
| 38 | |
---|
| 39 | # dh_installdeb will replace this with shell code automatically |
---|
| 40 | # generated by other debhelper scripts. |
---|
| 41 | |
---|
| 42 | #DEBHELPER# |
---|
| 43 | |
---|
| 44 | exit 0 |
---|
Note: See
TracBrowser
for help on using the repository browser.