Last change
on this file since 1314 was
1187,
checked in by price, 16 years ago
|
sipb-xen-console-server -> invirt-console-host
|
-
Property svn:executable set to
*
|
File size:
1.1 KB
|
Line | |
---|
1 | #!/bin/sh |
---|
2 | # postinst script for invirt-console-host |
---|
3 | # |
---|
4 | # see: dh_installdeb(1) |
---|
5 | |
---|
6 | set -e |
---|
7 | |
---|
8 | # summary of how this script can be called: |
---|
9 | # * <postinst> `configure' <most-recently-configured-version> |
---|
10 | # * <old-postinst> `abort-upgrade' <new version> |
---|
11 | # * <conflictor's-postinst> `abort-remove' `in-favour' <package> |
---|
12 | # <new-version> |
---|
13 | # * <postinst> `abort-remove' |
---|
14 | # * <deconfigured's-postinst> `abort-deconfigure' `in-favour' |
---|
15 | # <failed-install-package> <version> `removing' |
---|
16 | # <conflicting-package> <version> |
---|
17 | # for details, see http://www.debian.org/doc/debian-policy/ or |
---|
18 | # the debian-policy package |
---|
19 | |
---|
20 | |
---|
21 | case "$1" in |
---|
22 | configure) |
---|
23 | cat >>/etc/sudoers <<EOF |
---|
24 | ### BEGIN invirt-console-host |
---|
25 | conservr ALL=(ALL) NOPASSWD: /usr/sbin/xm console d_* |
---|
26 | ### END invirt-console-host |
---|
27 | EOF |
---|
28 | ;; |
---|
29 | |
---|
30 | abort-upgrade|abort-remove|abort-deconfigure) |
---|
31 | ;; |
---|
32 | |
---|
33 | *) |
---|
34 | echo "postinst called with unknown argument \`$1'" >&2 |
---|
35 | exit 1 |
---|
36 | ;; |
---|
37 | esac |
---|
38 | |
---|
39 | # dh_installdeb will replace this with shell code automatically |
---|
40 | # generated by other debhelper scripts. |
---|
41 | |
---|
42 | #DEBHELPER# |
---|
43 | |
---|
44 | exit 0 |
---|
Note: See
TracBrowser
for help on using the repository browser.