source: trunk/packages/invirt-cluster-config/debian/invirt-cluster-config.postinst @ 1520

Last change on this file since 1520 was 1520, checked in by broder, 15 years ago

Initial invirt-cluster-config package for configuring cman and clvm

File size: 992 bytes
Line 
1#!/bin/sh
2# postinst script for #PACKAGE#
3#
4# see: dh_installdeb(1)
5
6set -e
7
8# summary of how this script can be called:
9#        * <postinst> `configure' <most-recently-configured-version>
10#        * <old-postinst> `abort-upgrade' <new version>
11#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
12#          <new-version>
13#        * <postinst> `abort-remove'
14#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
15#          <failed-install-package> <version> `removing'
16#          <conflicting-package> <version>
17# for details, see http://www.debian.org/doc/debian-policy/ or
18# the debian-policy package
19
20# dh_installdeb will replace this with shell code automatically
21# generated by other debhelper scripts.
22
23#DEBHELPER#
24
25case "$1" in
26    configure)
27        invoke-rc.d cman restart
28    ;;
29
30    abort-upgrade|abort-remove|abort-deconfigure)
31    ;;
32
33    *)
34        echo "postinst called with unknown argument \`$1'" >&2
35        exit 1
36    ;;
37esac
38
39exit 0
40
Note: See TracBrowser for help on using the repository browser.