source: trunk/packages/invirt-base/debian/invirt-base.postinst @ 2941

Last change on this file since 2941 was 2941, checked in by broder, 14 years ago

Add code to invirt-reload to de-duplicate multiple invocations. (LP: #439426)

This uses the dpkg triggers mechanism to de-duplicate multiple
invocations of invirt-reload over the course of a single dpkg run.

The code is largely lifted from Ubuntu's update-initramfs.

  • Property svn:executable set to *
File size: 1.1 KB
Line 
1#!/bin/sh
2# postinst script for #PACKAGE#
3#
4# see: dh_installdeb(1)
5
6set -e
7
8# summary of how this script can be called:
9#        * <postinst> `configure' <most-recently-configured-version>
10#        * <old-postinst> `abort-upgrade' <new version>
11#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
12#          <new-version>
13#        * <postinst> `abort-remove'
14#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
15#          <failed-install-package> <version> `removing'
16#          <conflicting-package> <version>
17# for details, see http://www.debian.org/doc/debian-policy/ or
18# the debian-policy package
19
20
21case "$1" in
22    configure)
23    ;;
24
25    abort-upgrade|abort-remove|abort-deconfigure)
26    ;;
27
28    triggered)
29        if dpkg --compare-versions "$DPKG_RUNNING_VERSION" ge '1.14.5ubuntu10~~'; then
30            invirt-reload
31        else
32            DPKG_MAINTSCRIPT_PACKAGE='' invirt-reload
33        fi
34    ;;
35
36    *)
37        echo "postinst called with unknown argument \`$1'" >&2
38        exit 1
39    ;;
40esac
41
42# dh_installdeb will replace this with shell code automatically
43# generated by other debhelper scripts.
44
45#DEBHELPER#
46
47exit 0
48
49
Note: See TracBrowser for help on using the repository browser.