source: trunk/packages/hvirt-devconfig/debian/hvirt-devconfig.postinst @ 2785

Last change on this file since 2785 was 2785, checked in by gdb, 14 years ago

Fixed perlishness

File size: 1.2 KB
Line 
1#!/bin/sh
2# postinst script for #PACKAGE#
3#
4# see: dh_installdeb(1)
5
6set -e
7
8# summary of how this script can be called:
9#        * <postinst> `configure' <most-recently-configured-version>
10#        * <old-postinst> `abort-upgrade' <new version>
11#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
12#          <new-version>
13#        * <postinst> `abort-remove'
14#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
15#          <failed-install-package> <version> `removing'
16#          <conflicting-package> <version>
17# for details, see http://www.debian.org/doc/debian-policy/ or
18# the debian-policy package
19
20case "$1" in
21    configure)
22        # Need to do it like this to avoid shell injection
23        /usr/bin/perl -i -e '$r = `invirt-getconf kerberos.realm`; chomp($r);
24        while(<>) { s/^([ \t]*default_realm *=).*$/\1 $r/m; print; }' /etc/krb5.conf.invirt
25    ;;
26
27    abort-upgrade|abort-remove|abort-deconfigure)
28    ;;
29
30    triggered)
31    ;;
32
33    *)
34        echo "postinst called with unknown argument \`$1'" >&2
35        exit 1
36    ;;
37esac
38
39# dh_installdeb will replace this with shell code automatically
40# generated by other debhelper scripts.
41
42#DEBHELPER#
43
44exit 0
45
46
Note: See TracBrowser for help on using the repository browser.