Last change
on this file since 2813 was
2789,
checked in by gdb, 15 years ago
|
Added postinst to hvirt-devconfig to ensure config is regenerated
|
-
Property svn:executable set to
*
|
File size:
1.1 KB
|
Line | |
---|
1 | #!/bin/sh |
---|
2 | # postinst script for hvirt-devconfig |
---|
3 | # |
---|
4 | # see: dh_installdeb(1) |
---|
5 | |
---|
6 | set -e |
---|
7 | |
---|
8 | # summary of how this script can be called: |
---|
9 | # * <postinst> `configure' <most-recently-configured-version> |
---|
10 | # * <old-postinst> `abort-upgrade' <new version> |
---|
11 | # * <conflictor's-postinst> `abort-remove' `in-favour' <package> |
---|
12 | # <new-version> |
---|
13 | # * <postinst> `abort-remove' |
---|
14 | # * <deconfigured's-postinst> `abort-deconfigure' `in-favour' |
---|
15 | # <failed-install-package> <version> `removing' |
---|
16 | # <conflicting-package> <version> |
---|
17 | # for details, see http://www.debian.org/doc/debian-policy/ or |
---|
18 | # the debian-policy package |
---|
19 | |
---|
20 | |
---|
21 | case "$1" in |
---|
22 | configure) |
---|
23 | # Regen invirt config |
---|
24 | if hash invoke-rc.d; then |
---|
25 | invoke-rc.d invirt-base reload |
---|
26 | else |
---|
27 | /etc/init.d/invirt-base reload |
---|
28 | fi |
---|
29 | ;; |
---|
30 | |
---|
31 | abort-upgrade|abort-remove|abort-deconfigure) |
---|
32 | ;; |
---|
33 | |
---|
34 | triggered) |
---|
35 | invirt-reload |
---|
36 | ;; |
---|
37 | |
---|
38 | *) |
---|
39 | echo "postinst called with unknown argument \`$1'" >&2 |
---|
40 | exit 1 |
---|
41 | ;; |
---|
42 | esac |
---|
43 | |
---|
44 | # dh_installdeb will replace this with shell code automatically |
---|
45 | # generated by other debhelper scripts. |
---|
46 | |
---|
47 | #DEBHELPER# |
---|
48 | |
---|
49 | exit 0 |
---|
50 | |
---|
51 | |
---|
Note: See
TracBrowser
for help on using the repository browser.