source: package_branches/invirt-web/hvirt/debian/invirt-web.postinst @ 2913

Last change on this file since 2913 was 2913, checked in by gdb, 14 years ago

Made debian work with current invirt-web changes

  • Property svn:executable set to *
File size: 1.2 KB
Line 
1#!/bin/sh
2# postinst script for #PACKAGE#
3#
4# see: dh_installdeb(1)
5
6set -e
7
8# summary of how this script can be called:
9#        * <postinst> `configure' <most-recently-configured-version>
10#        * <old-postinst> `abort-upgrade' <new version>
11#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
12#          <new-version>
13#        * <postinst> `abort-remove'
14#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
15#          <failed-install-package> <version> `removing'
16#          <conflicting-package> <version>
17# for details, see http://www.debian.org/doc/debian-policy/ or
18# the debian-policy package
19
20
21case "$1" in
22    configure)
23        cd /var/www/invirt-web
24        make
25        a2dissite default
26        for mod in $(invirt-getconf web.mods); do
27            a2enmod ${mod}
28        done
29       
30        # Our init script proxies all requests to Apache's, so Apache's
31        # running is just a NOP
32        # update-rc.d -f apache2 remove
33    ;;
34
35    abort-upgrade|abort-remove|abort-deconfigure)
36    ;;
37
38    *)
39        echo "postinst called with unknown argument \`$1'" >&2
40        exit 1
41    ;;
42esac
43
44# dh_installdeb will replace this with shell code automatically
45# generated by other debhelper scripts.
46
47#DEBHELPER#
48
49exit 0
50
51
Note: See TracBrowser for help on using the repository browser.