source: package_branches/invirt-base/hvirt/debian/rules @ 2776

Last change on this file since 2776 was 2776, checked in by gdb, 14 years ago

Added debathena krb and ssh config stuff to invirt-base

  • Property svn:executable set to *
  • Property svn:mime-type set to text/script
File size: 1.3 KB
Line 
1#!/usr/bin/make -f
2
3DEB_PYTHON_SYSTEM=pysupport
4DEB_DIVERT_EXTENSION = .invirt
5# Stolen from Debathena
6DEB_CHECK_FILES_SOURCE_/etc/krb5.conf.invirt = \
7        /usr/share/kerberos-configs/krb5.conf.template
8DEB_TRANSFORM_FILES_invirt-base += \
9        /etc/krb5.conf.invirt
10
11include /usr/share/cdbs/1/rules/debhelper.mk
12include /usr/share/cdbs/1/class/python-distutils.mk
13include /usr/share/cdbs/1/rules/config-package.mk
14
15binary-fixup/invirt-base::
16        mv $(DEB_DESTDIR)usr/bin/invirt-reload $(DEB_DESTDIR)usr/sbin/invirt-reload
17
18# Stolen from Debathena
19debian/sshd_config.invirt-orig: /var/lib/dpkg/info/openssh-server.postinst
20        perl -0pe 's/^.*<<EOF[^\n]*\n(.*\n)EOF\n.*$$/$$1/s or die;' $< > $@
21
22# Stolen from Debathena
23debian/sshd_config.invirt: debian/sshd_config.invirt-orig
24        perl -0pe '# Debathena rules (from debathena-ssh-server-config) \
25s/^#?GSSAPIAuthentication .*$/GSSAPIAuthentication yes\nGSSAPIKeyExchange yes\nGSSAPIStrictAcceptorCheck no/m or die; \
26s/^#?GSSAPICleanupCredentials .*$/GSSAPICleanupCredentials yes/m or die; \
27s/^#?ChallengeResponseAuthentication .*$/ChallengeResponseAuthentication yes/m or die; \
28## In Debathena, privilege separation is configurable. \
29s/^#?UsePrivilegeSeparation .*$/UsePrivilegeSeparation yes/m or die; \
30s/^#?PasswordAuthentication .*$/PasswordAuthentication no/m or die;' $< > $@
31
32clean::
33        rm -rf python/invirt.egg-info
Note: See TracBrowser for help on using the repository browser.