Last change
on this file since 2786 was
2776,
checked in by gdb, 15 years ago
|
Added debathena krb and ssh config stuff to invirt-base
|
-
Property svn:executable set to
*
-
Property svn:mime-type set to
text/script
|
File size:
1.3 KB
|
Rev | Line | |
---|
[48] | 1 | #!/usr/bin/make -f |
---|
| 2 | |
---|
[1206] | 3 | DEB_PYTHON_SYSTEM=pysupport |
---|
[2776] | 4 | DEB_DIVERT_EXTENSION = .invirt |
---|
| 5 | # Stolen from Debathena |
---|
| 6 | DEB_CHECK_FILES_SOURCE_/etc/krb5.conf.invirt = \ |
---|
| 7 | /usr/share/kerberos-configs/krb5.conf.template |
---|
| 8 | DEB_TRANSFORM_FILES_invirt-base += \ |
---|
| 9 | /etc/krb5.conf.invirt |
---|
[1206] | 10 | |
---|
[725] | 11 | include /usr/share/cdbs/1/rules/debhelper.mk |
---|
[1206] | 12 | include /usr/share/cdbs/1/class/python-distutils.mk |
---|
[2776] | 13 | include /usr/share/cdbs/1/rules/config-package.mk |
---|
[49] | 14 | |
---|
[1330] | 15 | binary-fixup/invirt-base:: |
---|
[1218] | 16 | mv $(DEB_DESTDIR)usr/bin/invirt-reload $(DEB_DESTDIR)usr/sbin/invirt-reload |
---|
| 17 | |
---|
[2776] | 18 | # Stolen from Debathena |
---|
| 19 | debian/sshd_config.invirt-orig: /var/lib/dpkg/info/openssh-server.postinst |
---|
| 20 | perl -0pe 's/^.*<<EOF[^\n]*\n(.*\n)EOF\n.*$$/$$1/s or die;' $< > $@ |
---|
| 21 | |
---|
| 22 | # Stolen from Debathena |
---|
| 23 | debian/sshd_config.invirt: debian/sshd_config.invirt-orig |
---|
| 24 | perl -0pe '# Debathena rules (from debathena-ssh-server-config) \ |
---|
| 25 | s/^#?GSSAPIAuthentication .*$/GSSAPIAuthentication yes\nGSSAPIKeyExchange yes\nGSSAPIStrictAcceptorCheck no/m or die; \ |
---|
| 26 | s/^#?GSSAPICleanupCredentials .*$/GSSAPICleanupCredentials yes/m or die; \ |
---|
| 27 | s/^#?ChallengeResponseAuthentication .*$/ChallengeResponseAuthentication yes/m or die; \ |
---|
| 28 | ## In Debathena, privilege separation is configurable. \ |
---|
| 29 | s/^#?UsePrivilegeSeparation .*$/UsePrivilegeSeparation yes/m or die; \ |
---|
| 30 | s/^#?PasswordAuthentication .*$/PasswordAuthentication no/m or die;' $< > $@ |
---|
| 31 | |
---|
[1206] | 32 | clean:: |
---|
[1218] | 33 | rm -rf python/invirt.egg-info |
---|
Note: See
TracBrowser
for help on using the repository browser.