source: trunk/packages/xvm-munin-config/debian/xvm-munin-master-config.postinst @ 1761

Last change on this file since 1761 was 1761, checked in by broder, 15 years ago

Initial checkin of xvm-munin-config package

  • Property svn:executable set to *
File size: 1.8 KB
Line 
1#!/bin/sh
2# postinst script for #PACKAGE#
3#
4# see: dh_installdeb(1)
5
6set -e
7
8# summary of how this script can be called:
9#        * <postinst> `configure' <most-recently-configured-version>
10#        * <old-postinst> `abort-upgrade' <new version>
11#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
12#          <new-version>
13#        * <postinst> `abort-remove'
14#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
15#          <failed-install-package> <version> `removing'
16#          <conflicting-package> <version>
17# for details, see http://www.debian.org/doc/debian-policy/ or
18# the debian-policy package
19
20
21case "$1" in
22    configure)
23        # So munin can read the mail log
24        adduser munin adm
25       
26        # So munin can sudo to get to postfix queue info
27        cat >>/etc/sudoers <<EOF
28### BEGIN xvm-munin-config
29munin ALL=(postfix) SETENV: NOPASSWD: /etc/munin/plugins/postfix_mailqueue
30munin ALL=(munin) SETENV: NOPASSWD: ALL
31### END xvm-munin-config
32EOF
33       
34        # So munin can read from the database
35        su postgres -c 'createuser -S -D -R munin' || true
36        su postgres -c 'psql invirt --quiet' <<EOF
37GRANT SELECT ON pg_class TO munin;
38GRANT SELECT ON pg_index TO munin;
39GRANT SELECT ON pg_statio_user_tables TO munin;
40GRANT SELECT ON pg_stat_activity TO munin;
41GRANT SELECT ON pg_locks TO munin;
42EOF
43       
44        # Install munin plugins that are now configured
45        munin-node-configure --suggest --shell | sh
46       
47        invoke-rc.d munin-node restart
48    ;;
49
50    abort-upgrade|abort-remove|abort-deconfigure)
51    ;;
52
53    *)
54        echo "postinst called with unknown argument \`$1'" >&2
55        exit 1
56    ;;
57esac
58
59# dh_installdeb will replace this with shell code automatically
60# generated by other debhelper scripts.
61
62#DEBHELPER#
63
64exit 0
Note: See TracBrowser for help on using the repository browser.