source: trunk/packages/xvm-munin-config/debian/xvm-munin-host-config.postinst @ 2248

Last change on this file since 2248 was 2248, checked in by quentin, 15 years ago

Be more cautious about removing munin plugins

  • Property svn:executable set to *
File size: 1.8 KB
Line 
1#!/bin/sh
2# postinst script for #PACKAGE#
3#
4# see: dh_installdeb(1)
5
6set -e
7
8# summary of how this script can be called:
9#        * <postinst> `configure' <most-recently-configured-version>
10#        * <old-postinst> `abort-upgrade' <new version>
11#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
12#          <new-version>
13#        * <postinst> `abort-remove'
14#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
15#          <failed-install-package> <version> `removing'
16#          <conflicting-package> <version>
17# for details, see http://www.debian.org/doc/debian-policy/ or
18# the debian-policy package
19
20
21case "$1" in
22    configure)
23        # So munin can read the mail log
24        adduser munin adm
25       
26        # So munin can sudo to get to postfix queue info
27        # and smartctl info
28        # and info about running domains
29        cat >>/etc/sudoers <<EOF
30### BEGIN xvm-munin-config
31munin ALL=(postfix) SETENV: NOPASSWD: /etc/munin/plugins/postfix_mailqueue
32munin ALL=(munin) SETENV: NOPASSWD: ALL
33munin ALL=(root) SETENV: NOPASSWD: /etc/munin/plugins/hddtemp_smartctl , /etc/munin/plugins/smart_* , /etc/munin/plugins/xen_cpu
34### END xvm-munin-config
35EOF
36       
37        # Install munin plugins that are now configured
38        munin-node-configure --suggest --shell | sh
39
40        (cd /etc/munin/plugins &&
41            for i in smart_*; do
42                if smartctl -i "/dev/${i#smart_}" | grep Device | grep EQLOGIC; then
43                    rm -v "$i";
44                fi
45            done)
46       
47        invoke-rc.d munin-node restart
48    ;;
49
50    abort-upgrade|abort-remove|abort-deconfigure)
51    ;;
52
53    *)
54        echo "postinst called with unknown argument \`$1'" >&2
55        exit 1
56    ;;
57esac
58
59# dh_installdeb will replace this with shell code automatically
60# generated by other debhelper scripts.
61
62#DEBHELPER#
63
64exit 0
Note: See TracBrowser for help on using the repository browser.