source: trunk/packages/xvm-munin-config/debian/xvm-munin-host-config.postinst @ 1765

Last change on this file since 1765 was 1765, checked in by quentin, 15 years ago

Add xen_cpu plugin for monitoring domain CPU usage

  • Property svn:executable set to *
File size: 1.6 KB
Line 
1#!/bin/sh
2# postinst script for #PACKAGE#
3#
4# see: dh_installdeb(1)
5
6set -e
7
8# summary of how this script can be called:
9#        * <postinst> `configure' <most-recently-configured-version>
10#        * <old-postinst> `abort-upgrade' <new version>
11#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
12#          <new-version>
13#        * <postinst> `abort-remove'
14#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
15#          <failed-install-package> <version> `removing'
16#          <conflicting-package> <version>
17# for details, see http://www.debian.org/doc/debian-policy/ or
18# the debian-policy package
19
20
21case "$1" in
22    configure)
23        # So munin can read the mail log
24        adduser munin adm
25       
26        # So munin can sudo to get to postfix queue info
27        cat >>/etc/sudoers <<EOF
28### BEGIN xvm-munin-config
29munin ALL=(postfix) SETENV: NOPASSWD: /etc/munin/plugins/postfix_mailqueue
30munin ALL=(munin) SETENV: NOPASSWD: ALL
31munin ALL=(root) SETENV: NOPASSWD: /etc/munin/plugins/hddtemp_smartctl , /etc/munin/plugins/smart_* , /etc/munin/plugins/xen_cpu
32### END xvm-munin-config
33EOF
34       
35        # Install munin plugins that are now configured
36        munin-node-configure --suggest --shell | sh
37       
38        invoke-rc.d munin-node restart
39    ;;
40
41    abort-upgrade|abort-remove|abort-deconfigure)
42    ;;
43
44    *)
45        echo "postinst called with unknown argument \`$1'" >&2
46        exit 1
47    ;;
48esac
49
50# dh_installdeb will replace this with shell code automatically
51# generated by other debhelper scripts.
52
53#DEBHELPER#
54
55exit 0
Note: See TracBrowser for help on using the repository browser.