source: trunk/packages/xvm-iscsi-config/debian/xvm-iscsi-config.postinst @ 1510

Last change on this file since 1510 was 1510, checked in by broder, 15 years ago

Fix the installation of xvm-iscsi-config

  • Property svn:executable set to *
File size: 1.5 KB
Line 
1#!/bin/sh
2# postinst script for xvm-iscsi-config
3#
4# see: dh_installdeb(1)
5
6set -e
7
8# Source debconf library
9. /usr/share/debconf/confmodule
10
11# summary of how this script can be called:
12#        * <postinst> `configure' <most-recently-configured-version>
13#        * <old-postinst> `abort-upgrade' <new version>
14#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
15#          <new-version>
16#        * <postinst> `abort-remove'
17#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
18#          <failed-install-package> <version> `removing'
19#          <conflicting-package> <version>
20# for details, see http://www.debian.org/doc/debian-policy/ or
21# the debian-policy package
22
23# dh_installdeb will replace this with shell code automatically
24# generated by other debhelper scripts.
25
26#DEBHELPER#
27
28case "$1" in
29    configure)
30        db_get xvm-iscsi-config/address
31        ADDRESS="$RET"
32        db_get xvm-iscsi-config/username
33        USERNAME="$RET"
34        db_get xvm-iscsi-config/password
35        PASSWORD="$RET"
36        db_stop
37       
38        cat >/etc/invirt/conf.d/iscsi <<EOF
39iscsi:
40 address: $ADDRESS
41 username: $USERNAME
42 password: $PASSWORD
43EOF
44        invoke-rc.d xvm-iscsi-config restart
45        invoke-rc.d open-iscsi restart
46        iscsiadm -m discovery -t st -p $(invirt-getconf iscsi.address):3260
47    ;;
48
49    abort-upgrade|abort-remove|abort-deconfigure)
50    ;;
51
52    *)
53        echo "postinst called with unknown argument \`$1'" >&2
54        exit 1
55    ;;
56esac
57
58exit 0
Note: See TracBrowser for help on using the repository browser.