source: trunk/packages/sipb-xen-guest-installer/sipb-xen-guest-installer/debian/sipb-xen-guest-installer.postinst @ 222

Last change on this file since 222 was 222, checked in by price, 17 years ago

simplify isolinux.cfg.

Once we fix the problem of rebooting with the CD mounted again,
we can remove the prompt, so the user doesn't have to touch the console.
Until then, they need an opportunity to destroy/reboot-without-CD
after the installation finishes.

  • Property svn:executable set to *
File size: 1.5 KB
Line 
1#!/bin/sh
2# postinst script for sipb-xen-guest-installer
3#
4# see: dh_installdeb(1)
5
6set -e
7set -x
8
9# summary of how this script can be called:
10#        * <postinst> `configure' <most-recently-configured-version>
11#        * <old-postinst> `abort-upgrade' <new version>
12#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
13#          <new-version>
14#        * <postinst> `abort-remove'
15#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
16#          <failed-install-package> <version> `removing'
17#          <conflicting-package> <version>
18# for details, see http://www.debian.org/doc/debian-policy/ or
19# the debian-policy package
20
21
22case "$1" in
23    configure)
24        for d in /srv/guest-installer/*; do
25            # download the actual iso, unpack it, patch it.
26            wget -nc -i $d/iso.url -O $d/cdrom.orig.iso
27            MOUNTDIR=$(mktemp -d /mnt/sipb-xen-guest-installer.cdrom.XXXXXX)
28            mount -t iso9660 -o loop $d/cdrom.orig.iso $MOUNTDIR
29            rm -rf $d/cdrom.orig; cp -a $MOUNTDIR $d/cdrom.orig
30            umount $MOUNTDIR; rmdir $MOUNTDIR
31            rm -rf $d/cdrom; cp -a $d/cdrom.orig $d/cdrom
32            patch -d $d/cdrom -p1 <$d/cdrom.patch
33            tar cf - -C $d/cdrom.supplement . | tar xf - -C $d/cdrom
34        done
35    ;;
36
37    abort-upgrade|abort-remove|abort-deconfigure)
38    ;;
39
40    *)
41        echo "postinst called with unknown argument \`$1'" >&2
42        exit 1
43    ;;
44esac
45
46# dh_installdeb will replace this with shell code automatically
47# generated by other debhelper scripts.
48
49#DEBHELPER#
50
51exit 0
52
53
Note: See TracBrowser for help on using the repository browser.