source: trunk/packages/pyyaml/debian/rules @ 898

Last change on this file since 898 was 898, checked in by hartmans, 16 years ago

Add pyyaml and libyaml packages
backported from lenny.
There is discussion about how these should go in the repository; these are added in this form
in order to make forward progress.

  • Property svn:executable set to *
File size: 881 bytes
Line 
1#!/usr/bin/make -f
2
3DEB_PYTHON_SYSTEM=pycentral
4DEB_COMPRESS_EXCLUDE := .py
5
6include /usr/share/cdbs/1/rules/debhelper.mk
7include /usr/share/cdbs/1/class/python-distutils.mk
8include /usr/share/cdbs/1/rules/simple-patchsys.mk
9
10install/python-yaml::
11        for i in $(cdbs_python_build_versions); do \
12          python$$i ./setup_with_libyaml.py install --root $(CURDIR)/debian/python-yaml; \
13        done
14
15install/python-yaml-dbg::
16        for i in $(cdbs_python_build_versions); do \
17          python$$i-dbg ./setup_with_libyaml.py install --root $(CURDIR)/debian/python-yaml-dbg; \
18        done
19        find debian/python-yaml-dbg \
20          ! -type d ! -name '*_d.so' | xargs rm -f
21        find debian/python-yaml-dbg -depth -empty -exec rmdir {} \;
22
23binary-predeb/python-yaml-dbg::
24        rm -rf debian/python-yaml-dbg/usr/share/doc/python-yaml-dbg
25        ln -s python-yaml debian/python-yaml-dbg/usr/share/doc/python-yaml-dbg
26
27
28clean::
29        rm -rf build
Note: See TracBrowser for help on using the repository browser.