source: trunk/packages/invirt-vnc-server/debian/invirt-vnc-server.postinst @ 1388

Last change on this file since 1388 was 1388, checked in by broder, 16 years ago

Generate the VNC token key at invirt-vnc-server install-time instead
of hard-coding

  • Property svn:executable set to *
File size: 1.2 KB
Line 
1#!/bin/sh
2# postinst script for #PACKAGE#
3#
4# see: dh_installdeb(1)
5
6set -e
7
8# summary of how this script can be called:
9#        * <postinst> `configure' <most-recently-configured-version>
10#        * <old-postinst> `abort-upgrade' <new version>
11#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
12#          <new-version>
13#        * <postinst> `abort-remove'
14#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
15#          <failed-install-package> <version> `removing'
16#          <conflicting-package> <version>
17# for details, see http://www.debian.org/doc/debian-policy/ or
18# the debian-policy package
19
20
21case "$1" in
22    configure)
23        if [ -z "$2" ]; then
24            echo "Please be sure to copy vncproxy.crt and vncproxykey.pem into /usr/share/invirt-vnc-server/"
25        fi
26        mkdir -p /etc/invirt/secrets
27        if ! [ -e /etc/invirt/secrets/vnc-key ]; then
28            openssl rand -base64 33 >/etc/invirt/secrets/vnc-key
29        fi
30    ;;
31
32    abort-upgrade|abort-remove|abort-deconfigure)
33    ;;
34
35    *)
36        echo "postinst called with unknown argument \`$1'" >&2
37        exit 1
38    ;;
39esac
40
41# dh_installdeb will replace this with shell code automatically
42# generated by other debhelper scripts.
43
44#DEBHELPER#
45
46exit 0
47
48
Note: See TracBrowser for help on using the repository browser.