source: trunk/packages/invirt-remote-host/debian/changelog @ 1723

Last change on this file since 1723 was 1723, checked in by broder, 15 years ago

Use xm reboot instead of a destroy and create to reboot VMs

File size: 7.3 KB
Line 
1invirt-remote-host (0.0.9) unstable; urgency=low
2
3  * Use `xm reboot` for reboots instead of a destroy and create
4
5 -- Evan Broder <broder@mit.edu>  Thu, 20 Nov 2008 10:54:13 -0500
6
7invirt-remote-host (0.0.8) unstable; urgency=low
8
9  * I know this is the wrong answer, but doing lvchange -a n twice before
10    deleting an LV tends to make it less likely to error out
11
12 -- Evan Broder <broder@mit.edu>  Tue, 18 Nov 2008 11:55:22 -0500
13
14invirt-remote-host (0.0.7) unstable; urgency=low
15
16  * Actually remove the unused vmboot remctl
17
18 -- Evan Broder <broder@mit.edu>  Wed, 12 Nov 2008 18:27:48 -0500
19
20invirt-remote-host (0.0.6) unstable; urgency=low
21
22  * Use invoke-rc.d instead of calling init scripts directly
23
24 -- Evan Broder <broder@mit.edu>  Fri, 31 Oct 2008 06:27:38 -0400
25
26invirt-remote-host (0.0.5) unstable; urgency=low
27
28  * Add a `remote web vnccert` to print out the VNC certificate
29
30 -- Evan Broder <broder@mit.edu>  Tue, 28 Oct 2008 21:33:28 -0400
31
32invirt-remote-host (0.0.4) unstable; urgency=low
33
34  * Fix a typo in invirt-vmcontrol
35
36 -- Evan Broder <broder@mit.edu>  Tue, 28 Oct 2008 20:11:44 -0400
37
38invirt-remote-host (0.0.3) unstable; urgency=low
39
40  * Add support for a `remote control vnctoken` remctl for generating a
41    VNC auth token
42
43 -- Evan Broder <broder@mit.edu>  Tue, 28 Oct 2008 19:47:22 -0400
44
45invirt-remote-host (0.0.2) unstable; urgency=low
46
47  * sipb-database -> invirt-database
48
49 -- Evan Broder <broder@mit.edu>  Sat, 25 Oct 2008 18:05:17 -0400
50
51invirt-remote-host (0.0.1) unstable; urgency=low
52
53  * sipb-xen-remctl-auto -> invirt-remote-host
54
55 -- Evan Broder <broder@mit.edu>  Fri, 24 Oct 2008 21:54:35 -0400
56
57sipb-xen-remctl-auto (1.5.2) unstable; urgency=low
58
59  * sipb-xen-console-server -> invirt-console-host
60
61 -- Greg Price <price@mit.edu>  Fri, 24 Oct 2008 01:43:15 -0400
62
63sipb-xen-remctl-auto (1.5.1) unstable; urgency=low
64
65  * Return the new invalid-command error code in sipb-xen-vmcontrol
66
67 -- Evan Broder <broder@mit.edu>  Wed, 22 Oct 2008 00:51:34 -0400
68
69sipb-xen-remctl-auto (1.5) unstable; urgency=low
70
71  * Distinguish between Xen errors and invalid commands by returning a
72    completely outlandish error code that's not likely to conflict with
73    anything
74
75 -- Evan Broder <broder@mit.edu>  Wed, 22 Oct 2008 00:47:50 -0400
76
77sipb-xen-remctl-auto (1.4) unstable; urgency=low
78
79  * Correctly extract the CDROM image from the remctl arguments
80
81 -- Evan Broder <broder@mit.edu>  Sat, 18 Oct 2008 17:19:57 -0400
82
83sipb-xen-remctl-auto (1.3.1) unstable; urgency=low
84
85  * Quote the installer arguments correctly
86
87 -- Evan Broder <broder@mit.edu>  Fri, 10 Oct 2008 01:47:54 -0400
88
89sipb-xen-remctl-auto (1.3) unstable; urgency=low
90
91  * Respond to remctl install requests by passing the options onto Xen
92
93 -- Evan Broder <broder@mit.edu>  Thu, 09 Oct 2008 01:57:30 -0400
94
95sipb-xen-remctl-auto (1.2) unstable; urgency=low
96
97  * Exit successfully if inetd is already running; package fails to
98    install otherwise
99
100 -- Evan Broder <broder@mit.edu>  Mon, 06 Oct 2008 05:03:18 -0400
101
102sipb-xen-remctl-auto (1.1) unstable; urgency=low
103
104  * Explicitly lock a volume before deleting it
105
106 -- Evan Broder <broder@mit.edu>  Sun, 05 Oct 2008 18:01:34 -0400
107
108sipb-xen-remctl-auto (1.0.21) unstable; urgency=low
109
110  * start inetd too in init script
111
112 -- Greg Price <price@mit.edu>  Wed, 01 Oct 2008 20:43:29 -0400
113
114sipb-xen-remctl-auto (1.0.20) unstable; urgency=low
115
116  * generate config files using mako
117
118 -- Yang Zhang <y_z@mit.edu>  Thu, 14 Aug 2008 15:18:46 -0400
119
120sipb-xen-remctl-auto (1.0.19) unstable; urgency=low
121
122  * simplify the init script a la sipb-xen-dev
123
124 -- Yang Zhang <y_z@mit.edu>  Thu,  7 Aug 2008 22:09:28 -0400
125
126sipb-xen-remctl-auto (1.0.18) unstable; urgency=low
127
128  * use invirt config in sipb-xen-lvm
129  * added .init script to generate /etc/remctl/acl/remote
130  * sipb_xen_database -> invirt.database
131
132 -- Yang Zhang <y_z@mit.edu>  Sun,  3 Aug 2008 00:46:28 -0400
133
134sipb-xen-remctl-auto (1.0.17) unstable; urgency=low
135
136  * catch another version of the xenstore error in the listvms race
137
138 -- Greg Price <price@mit.edu>  Wed, 23 Jul 2008 01:12:01 -0400
139
140sipb-xen-remctl-auto (1.0.16) unstable; urgency=low
141
142  * support YAML as well as JSON (broder, quentin, andersk, long ago)
143  * fix a race in listvms when a machine is shutting down
144
145 -- Greg Price <price@mit.edu>  Tue, 22 Jul 2008 23:46:49 -0400
146
147sipb-xen-remctl-auto (1.0.15) unstable; urgency=low
148
149  * Compute time differences on server to avoid drift
150
151 -- Quentin Smith <quentin@mit.edu>  Thu, 15 May 2008 20:58:04 -0400
152
153sipb-xen-remctl-auto (1.0.14) unstable; urgency=low
154
155  * Use more efficient python API to get VM information, and return it
156    in a Python dict structure.
157
158 -- Quentin Smith <quentin@mit.edu>  Thu, 15 May 2008 20:29:03 -0400
159
160sipb-xen-remctl-auto (1.0.13) unstable; urgency=low
161
162  * Switch to just using the remote server.
163
164 -- Greg Price <price@mit.edu>  Sat, 10 May 2008 21:26:42 -0400
165
166sipb-xen-remctl-auto (1.0.12) unstable; urgency=low
167
168  * Remove an obsolete line from the remctl config.
169
170 -- Greg Price <price@mit.edu>  Sun,  4 May 2008 22:36:07 -0400
171
172sipb-xen-remctl-auto (1.0.11) unstable; urgency=low
173
174  * Close file descriptors for update-conserver on destroy/shutdown.
175
176 -- Eric Price <ecprice@pseudomyrmex.mit.edu>  Mon, 21 Apr 2008 21:28:12 -0400
177
178sipb-xen-remctl-auto (1.0.10) unstable; urgency=low
179
180  * Delay running sipb-xen-update-conserver
181
182 -- Evan Broder <broder@mit.edu>  Mon, 21 Apr 2008 20:26:28 -0400
183
184sipb-xen-remctl-auto (1.0.9) unstable; urgency=low
185
186  * Change the way that conserver is updated
187
188 -- Evan Broder <broder@sipb-xen-dev.mit.edu>  Wed,  2 Apr 2008 04:36:04 -0400
189
190sipb-xen-remctl-auto (1.0.8) unstable; urgency=low
191
192  * Add support for updating conserver when VMs are turned on and off
193
194 -- Evan Broder <broder@sipb-xen-dev.mit.edu>  Wed,  2 Apr 2008 00:40:23 -0400
195
196sipb-xen-remctl-auto (1.0.7) unstable; urgency=low
197
198  * changes for installer system
199
200 -- Tim Abbott <tabbott@sipb-xen-dev.mit.edu>  Sun, 28 Oct 2007 22:47:59 -0400
201
202sipb-xen-remctl-auto (1.0.6) unstable; urgency=low
203
204  * get rid of old "vmboot" call
205  * make "create" not destroy running machines.
206
207 -- Tim Abbott <tabbott@sipb-xen-dev.mit.edu>  Sat, 27 Oct 2007 16:54:26 -0400
208
209sipb-xen-remctl-auto (1.0.5) unstable; urgency=low
210
211  * move to common /usr/sbin/sipb-xen-* naming
212  * get rid of dispatch.sh hack
213  * fix "reboot" to "destroy then create" always, since that's what users will expect
214  * change remctl calls interface in various ways
215
216 -- Tim Abbott <tabbott@mit.edu>  Tue, 16 Oct 2007 00:28:36 -0400
217
218sipb-xen-remctl-auto (1.0.4) unstable; urgency=low
219
220  * Fix typos.
221
222 -- Anders Kaseorg <andersk@sipb-xen-dev.mit.edu>  Tue,  9 Oct 2007 04:47:37 -0400
223
224sipb-xen-remctl-auto (1.0.3) unstable; urgency=low
225
226  * Prepend d_ to database VMs.
227
228 -- Eric Price <ecprice@sipb-xen-dev.mit.edu>  Tue,  9 Oct 2007 02:34:56 -0400
229
230sipb-xen-remctl-auto (1.0.2) unstable; urgency=low
231
232  * Added web interface support code.
233  * Move things from /etc/remctl/sipb-xen-auto/bin to /usr/sbin
234  * Quoted lots of variables
235
236 -- Tim Abbott <tabbott@sipb-xen-dev.mit.edu>  Sun,  7 Oct 2007 17:23:40 -0400
237
238sipb-xen-remctl-auto (1.0.1) unstable; urgency=low
239
240  * Stop scaring me with unquoted variables.
241
242 -- Anders Kaseorg <andersk@mit.edu>  Sun, 05 Aug 2007 22:11:02 -0400
243
244sipb-xen-remctl-auto (1.0) unstable; urgency=low
245
246  * Initial release.
247
248 -- Tim Abbott <tabbott@mit.edu>  Sun, 15 Jul 2007 19:37:05 -0400
Note: See TracBrowser for help on using the repository browser.