source: trunk/packages/invirt-dev/debian/invirt-dev.postinst @ 1322

Last change on this file since 1322 was 1322, checked in by price, 16 years ago

sipb-xen-dev -> invirt-dev

File size: 699 bytes
Line 
1#!/bin/sh
2set -e
3
4#DEBHELPER#
5
6case "$1" in
7    configure)
8        if [ -z "$2" ]; then
9            adduser --system repository
10            addgroup --system repo
11            echo "%repo   ALL=(repository)        ALWAYS_SET_HOME,NOPASSWD: /usr/bin/reprepro" >>/etc/sudoers
12            echo "-----"
13            echo "invirt-dev: run"
14            echo "  adduser --disabled-password \$user"
15            echo "  adduser \$user repo"
16            echo "to make individual users that will build packages."
17            echo "-----"
18        fi
19    ;;
20
21    abort-upgrade|abort-remove|abort-deconfigure)
22    ;;
23
24    *)
25        echo "postinst called with unknown argument \`$1'" >&2
26        exit 1
27    ;;
28esac
Note: See TracBrowser for help on using the repository browser.