source: trunk/packages/invirt-database/debian/changelog @ 2198

Last change on this file since 2198 was 2198, checked in by price, 15 years ago

invirt-quota: fix imports EIBTI-style

also needn't call int() on value from optparse

File size: 13.4 KB
Line 
1invirt-database (0.1.8) unstable; urgency=low
2
3  [Peter Iannucci]
4  * Added Record superclass for models, handling __repr__ consistently.
5
6  [Greg Price]
7  invirt.database.record, .owner:
8  * use self.c rather than self.__dict__ for SQLAlchemy fields
9  * make Record._ignore, Owner.get* classmethods
10  * fold FormattableRecord, NullableRecord into Record
11  * shorten types in lists to __name__
12 
13  invirt-quota:
14  * refactor code that sets values
15  * print full help on no arguments
16  * make EIBTI imports
17
18 -- Greg Price <price@mit.edu>  Fri, 27 Feb 2009 02:16:28 -0500
19
20invirt-database (0.1.7) unstable; urgency=low
21
22  * Disk quotas are measured in gibibytes.
23  * Rename invirt-setquotas to invirt-quota.
24  * Be explicit about units in invirt-quota.
25
26 -- Evan Broder <broder@mit.edu>  Tue, 17 Feb 2009 04:29:20 -0500
27
28invirt-database (0.1.6) unstable; urgency=low
29
30  * Move invirt-setquotas into this package.
31  * Don't explicitly initialize the values for each quota when creating a
32    new Owner object.
33
34 -- Evan Broder <broder@mit.edu>  Tue, 17 Feb 2009 03:44:20 -0500
35
36invirt-database (0.1.5) unstable; urgency=low
37
38  * Make the default values on the owners table explicit
39    (Note: This is a NOOP, since a nullable field with no otherwise
40    specified default defaults to NULL)
41
42 -- Evan Broder <broder@mit.edu>  Tue, 17 Feb 2009 03:36:47 -0500
43
44invirt-database (0.1.4) unstable; urgency=low
45
46  * minor bug fix
47
48 -- Peter A. Iannucci <iannucci@mit.edu>  Tue, 17 Feb 2009 02:59:14 -0500
49
50invirt-database (0.1.3) unstable; urgency=low
51
52  * Added owner table to database with ram, disk, and VM quotas
53  * Refactored Owner class into separate sourcefile
54
55 -- Peter A. Iannucci <iannucci@mit.edu>  Tue, 17 Feb 2009 01:31:53 -0500
56
57invirt-database (0.1.2) unstable; urgency=low
58
59  * Clean up the .egg-info directory from the right place.
60
61 -- Evan Broder <broder@mit.edu>  Mon, 05 Jan 2009 23:50:47 -0500
62
63invirt-database (0.1.1) unstable; urgency=low
64
65  * Correct a lintian spelling warning.
66
67 -- Evan Broder <broder@mit.edu>  Mon, 05 Jan 2009 23:40:44 -0500
68
69invirt-database (0.1.0) unstable; urgency=low
70
71  * Turn on lazy loading for all tables
72
73 -- Evan Broder <broder@mit.edu>  Mon, 17 Nov 2008 21:57:35 -0500
74
75invirt-database (0.0.6) unstable; urgency=low
76
77  * Let machines.administrator be NULL
78
79 -- Evan Broder <broder@mit.edu>  Mon, 17 Nov 2008 13:41:48 -0500
80
81invirt-database (0.0.5) unstable; urgency=low
82
83  * Add an architecture field to the autoinstaller table
84
85 -- Evan Broder <broder@mit.edu>  Mon, 17 Nov 2008 12:18:02 -0500
86
87invirt-database (0.0.3) unstable; urgency=low
88
89  * Add attributes to the ORM objects to connect mirrors and cdroms
90
91 -- Evan Broder <broder@mit.edu>  Tue, 28 Oct 2008 03:16:18 -0400
92
93invirt-database (0.0.2) unstable; urgency=low
94
95  * Export mirrors_table and Mirrors from invirt.database.models
96
97 -- Evan Broder <broder@mit.edu>  Tue, 28 Oct 2008 03:04:54 -0400
98
99invirt-database (0.0.1) unstable; urgency=low
100
101  * sipb-xen-database-common -> invirt-database
102  * sipb-xen-database-server -> invirt-database-server (a separate source package)
103  * sipb-xen-database-client -> invirt-xen-config
104
105 -- Evan Broder <broder@mit.edu>  Sat, 25 Oct 2008 19:22:46 -0400
106
107sipb-xen-database (10.36.1) unstable; urgency=low
108
109  * Typo in the new tables
110
111 -- Evan Broder <broder@mit.edu>  Sat, 25 Oct 2008 15:01:47 -0400
112
113sipb-xen-database (10.36) unstable; urgency=low
114
115  * Kill the remnants of the sipb_xen_database package
116  * Add the CDROM mirrors table
117
118 -- Evan Broder <broder@mit.edu>  Sat, 25 Oct 2008 14:48:32 -0400
119
120sipb-xen-database (10.35) unstable; urgency=low
121
122  * Shorten initscript with spiffy new library from sipb-xen-base
123
124 -- Greg Price <price@mit.edu>  Fri, 24 Oct 2008 07:25:56 -0400
125
126sipb-xen-database (10.34) unstable; urgency=low
127
128  * yet another new-sqlalchemy fix, this one post-0.4.2
129
130 -- Greg Price <price@mit.edu>  Thu, 23 Oct 2008 23:02:46 -0400
131
132sipb-xen-database (10.33) unstable; urgency=low
133
134  * Catch calls to restart Postgres and translate them into a sequential
135    stop, then start
136
137 -- Evan Broder <broder@mit.edu>  Mon, 20 Oct 2008 13:05:29 -0400
138
139sipb-xen-database (10.32) unstable; urgency=low
140
141  * invirt.database.clear_cache should actually do something
142
143 -- Evan Broder <broder@mit.edu>  Sun, 19 Oct 2008 02:02:37 -0400
144
145sipb-xen-database (10.31) unstable; urgency=low
146
147  * Database-managed VMs should never even think about bridging
148
149 -- Evan Broder <broder@mit.edu>  Sun, 19 Oct 2008 01:46:45 -0400
150
151sipb-xen-database (10.30.4) unstable; urgency=low
152
153  * Fix a typo in the CDROM image path
154
155 -- Evan Broder <broder@mit.edu>  Wed, 15 Oct 2008 13:21:10 -0400
156
157sipb-xen-database (10.30.3) unstable; urgency=low
158
159  * fix copy-paste errors in initscript: this is database, not console
160  * fix "typo" in initscript for package name printed in logs
161
162 -- Greg Price <price@mit.edu>  Sat, 11 Oct 2008 17:50:11 -0700
163
164sipb-xen-database (10.30.2) unstable; urgency=low
165
166  * Fix a typo in the CDROM lookup in sipb-database
167
168 -- Evan Broder <broder@mit.edu>  Sat, 11 Oct 2008 19:17:05 -0400
169
170sipb-xen-database (10.30.1) unstable; urgency=low
171
172  * Don't strip quotes that won't be there
173
174 -- Evan Broder <broder@mit.edu>  Fri, 10 Oct 2008 01:48:48 -0400
175
176sipb-xen-database (10.30) unstable; urgency=low
177
178  * Look for CD images in /dev/xenvg/image_* and validate image name from
179    the database
180  * Pass the installer arguments unaltered to the kernel, matching the
181    remctl interface
182
183 -- Evan Broder <broder@mit.edu>  Thu, 09 Oct 2008 02:09:42 -0400
184
185sipb-xen-database (10.29) unstable; urgency=low
186
187  * Some fixes in the sipb-database script
188
189 -- Evan Broder <broder@mit.edu>  Mon, 06 Oct 2008 18:55:24 -0400
190
191sipb-xen-database (10.28) unstable; urgency=low
192
193  * Re-establish the database connection if the server goes AWOL
194
195 -- Evan Broder <broder@mit.edu>  Sat, 04 Oct 2008 23:19:59 -0400
196
197sipb-xen-database (10.27) unstable; urgency=low
198
199  * Update sipb-database to work with newer SQLAlchemy and Xen
200
201 -- Evan Broder <broder@mit.edu>  Fri, 03 Oct 2008 20:08:16 -0400
202
203sipb-xen-database (10.26.1) unstable; urgency=low
204
205  * We want autoflush off, too
206
207 -- Evan Broder <broder@mit.edu>  Fri, 03 Oct 2008 19:22:12 -0400
208
209sipb-xen-database (10.26) unstable; urgency=low
210
211  * Disable transactions by default
212
213 -- Evan Broder <broder@mit.edu>  Thu, 02 Oct 2008 19:40:34 -0400
214
215sipb-xen-database (10.25) unstable; urgency=low
216
217  * add remote and console to pg_hba.conf template
218  * fix init script so it works
219  * port more code to sqlalchemy 0.4
220
221 -- Greg Price <price@mit.edu>  Wed, 01 Oct 2008 19:30:26 -0400
222
223sipb-xen-database (10.24) unstable; urgency=low
224
225  * Update postgresql.conf for Hardy
226
227 -- Evan Broder <broder@mit.edu>  Wed, 01 Oct 2008 03:12:36 -0400
228
229sipb-xen-database (10.23) unstable; urgency=low
230
231  * switch to postgresql 8.3, as 8.1 isn't in hardy
232
233 -- Greg Price <price@mit.edu>  Wed, 01 Oct 2008 02:09:43 -0400
234
235sipb-xen-database (10.22) unstable; urgency=low
236
237  * depend on postgresql without specifying old version 8.1
238
239 -- Greg Price <price@mit.edu>  Wed, 01 Oct 2008 01:55:49 -0400
240
241sipb-xen-database (10.21) unstable; urgency=low
242
243  * fix distribution
244
245 -- Greg Price <price@mit.edu>  Tue, 30 Sep 2008 23:50:25 -0400
246
247sipb-xen-database (10.20) hardy; urgency=low
248
249  * port to sqlalchemy-0.4, which cuts out some newly deprecated
250    interfaces and allowed some still-present interfaces to bitrot
251
252 -- Greg Price <price@mit.edu>  Mon, 29 Sep 2008 06:06:21 +0000
253
254sipb-xen-database (10.19) unstable; urgency=low
255
256  * Generate config files for pg_hba.conf
257  * replace postgresql.conf
258
259 --  Sam Hartman <hartmans@xvm.mit.edu>  Mon, 25 Aug 2008 00:38:21 +0000
260
261sipb-xen-database (10.18) unstable; urgency=low
262
263  * add 'adminable' column to machines; for selectively, temporarily,
264    enabling admin mode on a machine
265
266 -- Greg Price <price@mit.edu>  Wed,  6 Aug 2008 01:02:59 -0400
267
268sipb-xen-database (10.17) unstable; urgency=low
269
270  * pull IP gateway, network from config
271  * configurabilization complete!
272
273 -- Greg Price <price@mit.edu>  Sun,  3 Aug 2008 01:16:53 -0400
274
275sipb-xen-database (10.16) unstable; urgency=low
276
277  in sipb-xen-database-tables:
278  * use invirt.database, and take default db uri
279
280 -- Greg Price <price@mit.edu>  Sun,  3 Aug 2008 00:51:32 -0400
281
282sipb-xen-database (10.15) unstable; urgency=low
283
284  in /etc/xen/database:
285  * uncommitted changes on black-mesa
286  * sipb_xen_database -> invirt.database
287  * use default db uri
288
289  in invirt.database:
290  * get default db uri from invirt.config
291
292 -- Greg Price <price@mit.edu>  Sun,  3 Aug 2008 00:26:46 -0400
293
294sipb-xen-database (10.14) unstable; urgency=low
295
296  * Rename sipb_xen_database -> invirt.database,
297    keeping old name too for now, for compatibility.
298
299 -- Greg Price <price@mit.edu>  Sat,  2 Aug 2008 23:19:18 -0400
300
301sipb-xen-database (10.13) unstable; urgency=low
302
303  * Modify autoinstalls table to specify distribution/mirror.
304
305 -- Eric Price <ecprice@pseudomyrmex.mit.edu>  Sat, 21 Jun 2008 21:25:21 -0400
306
307sipb-xen-database (10.12) unstable; urgency=low
308
309  * Add a description field.
310
311 -- Anders Kaseorg <andersk@mit.edu>  Wed, 18 Jun 2008 03:52:49 -0400
312
313sipb-xen-database (10.11) unstable; urgency=low
314
315  * Specify ON DELETE CASCADE
316
317 -- Eric Price <ecprice@pseudomyrmex.mit.edu>  Fri, 06 Jun 2008 12:25:35 -0400
318
319sipb-xen-database (10.10) unstable; urgency=low
320
321  * Make machine.acl a private relation.
322
323 -- Eric Price <ecprice@pseudomyrmex.mit.edu>  Fri, 06 Jun 2008 12:03:09 -0400
324
325sipb-xen-database (10.9) unstable; urgency=low
326
327  * Eager loading of relations for better performance.
328
329 -- Eric Price <ecprice@pseudomyrmex.mit.edu>  Mon, 02 Jun 2008 01:39:11 -0400
330
331sipb-xen-database (10.8) unstable; urgency=low
332
333  * Configure serial console on boot
334
335 -- Quentin Smith <quentin@sipb-xen-dev.mit.edu>  Thu,  1 May 2008 20:21:25 -0400
336
337sipb-xen-database (10.7) unstable; urgency=low
338
339  * Depend on psql client in -client package.
340
341 -- Greg Price <price@mit.edu>  Sat, 26 Apr 2008 21:06:41 -0400
342
343sipb-xen-database (10.6) unstable; urgency=low
344
345  * Support autoinstalls table.
346
347 -- Eric Price <ecprice@pseudomyrmex.mit.edu>  Mon, 21 Apr 2008 22:34:46 -0400
348
349sipb-xen-database (10.5) unstable; urgency=low
350
351  * Enable USB tablet device in guests.
352
353 -- Anders Kaseorg <andersk@mit.edu>  Mon, 21 Apr 2008 17:39:59 -0400
354
355sipb-xen-database (10.4.1) unstable; urgency=low
356
357  * Actually export the cache clearing function.
358
359 -- Eric Price <ecprice@pseudomyrmex.mit.edu>  Fri, 28 Mar 2008 21:18:01 -0400
360
361sipb-xen-database (10.4) unstable; urgency=low
362
363  * Ubuntu's dch sucks.
364
365 -- Eric Price <ecprice@sipb-xen-dev.mit.edu>  Fri, 28 Mar 2008 20:43:42 -0400
366
367sipb-xen-database (10.3ubuntu1) gutsy; urgency=low
368
369  * Expose a function for clearing the cache.
370
371 -- Eric Price <ecprice@pseudomyrmex.mit.edu>  Fri, 28 Mar 2008 20:31:06 -0400
372
373sipb-xen-database (10.3) unstable; urgency=low
374
375  * Use 'acl', not 'users', for the reference to the machine_access table.
376
377 -- Eric Price <ecprice@sipb-xen-dev.mit.edu>  Thu, 24 Jan 2008 17:23:33 -0500
378
379sipb-xen-database (10.2) unstable; urgency=low
380
381  * Add MachineAccess to __all__ so it can be imported
382  * Remove unnecessary constructors for database objects
383
384 -- Quentin Smith <quentin@sipb-xen-dev.mit.edu>  Mon, 12 Nov 2007 04:53:47 -0500
385
386sipb-xen-database (10.1) unstable; urgency=low
387
388  * Make sipb-xen-database-tables safer (don't default to drop_all)
389
390 -- Quentin Smith <quentin@sipb-xen-dev.mit.edu>  Mon, 12 Nov 2007 04:39:59 -0500
391
392sipb-xen-database (10) unstable; urgency=low
393
394  * Added a machine_access table for cached ACLs
395
396 -- Quentin Smith <quentin@sipb-xen-dev.mit.edu>  Mon, 12 Nov 2007 04:24:35 -0500
397
398sipb-xen-database (9.0) unstable; urgency=low
399
400  * No changes.
401
402 -- Eric Price <ecprice@sipb-xen-dev.mit.edu>  Wed, 10 Oct 2007 00:17:20 -0400
403
404sipb-xen-database (9) unstable; urgency=low
405
406  * Add administrator column and backrefs to machine.
407
408 -- Eric Price <ecprice@sipb-xen-dev.mit.edu>  Wed, 10 Oct 2007 00:11:47 -0400
409
410sipb-xen-database (8) gutsy; urgency=low
411
412  * Prepend d_ to database VMs.
413
414 -- Eric Price <ecprice@sipb-xen-dev.mit.edu>  Tue,  9 Oct 2007 02:35:51 -0400
415
416sipb-xen-database (7.00002) gutsy; urgency=low
417
418  * Actually import re.
419
420 -- Anders Kaseorg <andersk@mit.edu>  Sun, 07 Oct 2007 04:34:07 -0400
421
422sipb-xen-database (7.00001) gutsy; urgency=low
423
424  * import re.
425
426 -- Anders Kaseorg <andersk@mit.edu>  Sun, 07 Oct 2007 03:40:25 -0400
427
428sipb-xen-database (7) unstable; urgency=low
429
430  * nics primary key should be mac address, not hostname.
431  * Make ip unique, and constructor for nics.
432  * Add a table for boot CDs.
433  * Add cdrom_image parameter.
434  * Regex sanity checking.
435
436 -- Anders Kaseorg <andersk@mit.edu>  Sun, 07 Oct 2007 03:18:30 -0400
437
438sipb-xen-database (6) unstable; urgency=low
439
440  * Adding a script to create lvm volumes
441
442 -- Nelson Elhage <nelhage@mit.edu>  Sat, 22 Sep 2007 13:59:36 -0400
443
444sipb-xen-database (5) unstable; urgency=low
445
446  * Change the host from sipb-vm-1 to sipb-xen-dev
447
448 -- Nelson Elhage <nelhage@mit.edu>  Sat,  8 Sep 2007 16:16:07 -0400
449
450sipb-xen-database (4) unstable; urgency=low
451
452  * Add script=vif-sipbroute to our vif lines
453
454 -- Nelson Elhage <nelhage@mit.edu>  Fri, 24 Aug 2007 22:07:18 -0400
455
456sipb-xen-database (3) unstable; urgency=low
457
458  * Add a connect() line to sipb-database
459  * Fix some other bugs in sipb-database
460
461 -- Nelson Elhage <nelhage@mit.edu>  Sun, 19 Aug 2007 19:40:08 -0400
462
463sipb-xen-database (2) unstable; urgency=low
464
465  * Fix the postinit and prerm scripts to create a sipb-xen user
466
467 -- Nelson Elhage <nelhage@mit.edu>  Thu, 16 Aug 2007 16:27:36 -0400
468
469sipb-xen-database (1) unstable; urgency=low
470
471  * Initial Release.
472
473 -- Nelson Elhage <nelhage@mit.edu>  Sun, 15 Jul 2007 16:01:16 -0400
Note: See TracBrowser for help on using the repository browser.